US PvE Exiled Lands... stuck in loading screen

I’ve tried multiple times today to log into the server, and keep getting stuck in the loading screen. The progress bar is full, the music is playing, but the server doesn’t let me in. I’ve been in the loading screen for about an hour. No mods loaded, nothing else running on the computer.

I’ve restarted, verified my files, and even used a different steam account… same result.

any ideas?

1 Like

Try reading the forum?
Shut Conan down, shut steam down, try again.

Yes, I looked through the topics, and none of them sounded like my problem.

I did as you suggested with no luck. Only difference is I finally got a message that said "Could not connect you to the server… the connection to the host has been lost.

The steps I took previously would/should have had the same affect as your recommendation, but I did it anyway, because who knows… for the record, I can connect to other servers just fine.

A few days ago one of my fellow US PvPers posted a request for a reboot, which was answered saying that it had been done, but the server has been getting steadily worse every day since before that with no improvement… I don’t think the reboot actually happened. I think the server needs some lovin from the people who are paid to support them, but it’s being neglected for some unknown reason. I don’t see how they expect us to report bugs when we constantly struggle through stability issues. Bugs can’t even happen if the server has us locked in place, or won’t let us in.

1 Like

I am also have problems connecting today. Stays stuck on the loading screen. Did everything people recommended. It’s just this server. All the others were fine to load.

Sounds like the public beta is done. Funcom sort of lets the servers go once they are ready to go live.

I am having the same problem. No clue here. Did all the same things you did and nothing.

Public beta is done.

Chapter 3.
“So, grab your torch, team up with some friends, and prepare yourself to save the exiled lands from darkness on March 14th, 2023.”

Same problem here. Server list shows that 3 players are online, but I am stuck at the loading screen.

I will say this from a test that I did in SP with 2 players in co-op.

3 players - 6 thralls (Warrior of Sobek). Blood Moon Beast one-shot killed all of the thralls and each of the players. That is EFFING ridiculous. Seriously, we went back multiple times and were constantly one-shot killed while actively trying to avoid it. I do not see how that is considered fun. I do not mind a challenging fight, but FFS, what the hell?

I am unable to log onto the US PVE Beta server. I have a character there but can’t get on. The logging status bars are very slow, usually it does not take much time for them to progress to max. I have verified the integrity of the game files but it does not help. The status bars will go to max and just stop, nothing. I waited 15 minutes once and did not even get a time out error message. Just nothing.

The update goes live tomorrow, as far as I know the public beta is done.

Greetings everyone,

Thank you for pointing this out to us. We’re currently looking into this situation.

EDIT: The issue should now be resolved. Please restart the game and try to connect to any of our Beta servers.
If you are still experiencing this issue, feel free to get back to us and let us know.

1 Like

Freudian slip :thinking:

1 Like

:face_with_hand_over_mouth: Ups, fixed it. Apologies for that.

1 Like

there is no local solution for that, it seems to be a server side problem that solves temporally by reseting the server, but after some hours the problem returns, various offical pve-c server sufering this, specially the 1977 since chapter 2. Maybe its a good thing it showing up in testlive too, this way it can get reproduced and fixed.

will it being patched on chapter three?

Jim Bean Dancing GIF - Find & Share on GIPHY

You ever played through a cycle on the public beta servers? I have a few times. And we’ll not get in to bug reports I have filed while in test that went and are still live. I can practically guaranty when Chapter 3 hits live tomorrow it will hit live with the majority of reported bugs still in it. The public beta is pretty much testing for game breakers and server crashers.

I gave up on the public beta servers. Hell it was just chapter 2 when they actually started server restarts when players asked. When Sorcery first hit most of the time there was only 1 server working the rest were ??? 9999. They got restarted when the devs dropped updates to test, couple days later ??? 9999.

I expect Tuesday and Wednesday to be a brouhaha.

1 Like

oh man sad to hear it.

Hopefully the servers aren’t left to languish too much; they’ve kinda become my vanilla playground when my buddy’s server becomes to political… or broken. XD

Nope, the server is not fixed. Just tried to log in, and still can’t, but I can get on the PVE-C server just fine.

Now the US PVE-C server is offline just like this one.
Is anyone reading these?