Using Alt+Tab while loading a game causes crash to desktop

Game mode Online private or Single-player
Mods None
Type of issue Bug
Server type PvE
Region North America
Version 196231/23625

Due to the slowish loading time of getting connected to an online or your own singleplayer experience, I often find myself using Alt-Tab to switch to Discord or Steam chat windows.

This is causing the game to abnormally exit to the desktop with the white Funcom crash reporting tool popping up.

Since this has happened at least four times today, why not document and report it?

Workaround: Know that this game is going to crash and don’t switch contexts until the game is fully rendered.

Steps to Reproduce:

  • Launch the game
  • Wait for the intro videos to complete, but they rarely even play properly, so you’re just looking at a still image while listening to audio
  • Don’t Alt-Tab here, the program will become non-responsive
  • Get to the Main Menu
  • Select either your Single-player game or Online game
  • Press Join
  • Press Alt-Tab to switch to another window
  • Listening to game music for a moment, then wait for the crash
  • Oops, your game crashed. Now you need to relaunch it and remember not to Alt-Tab until it has fully loaded you into the game.

try setting to windowned fullscreen, if you haven’t tried that yet.

Additionally, Bedwin, you may want to do this:
Find “F:\Steam\steamapps\common\Conan Exiles\ConanSandbox\Config\DefaultGame.ini” (your path will vary, but you want DefaultGame.ini) and open it. If you are uncomfortable, make a backup copy first.

Scroll down and find:
Change that to:

Save the file and start the game.

You will have to change that each major update, but it makes loading so much faster since you are no longer awaiting the movies (if you are). If your movies are over and the game has yet to load, you may want to consider an SSD.



Thank you, Skillo and Jim1

I have been using just Fullscreen, but tested out switching to Windowed Fullscreen. So far, I was able to get it to crash again once. Might require a full termination and reload to take effect, maybe?

Jim, I still have that setting enabled from an earlier tip you shared. It’s a great suggestion, to regain control over our user experience. Not that I don’t appreciate the work that went into making the game opening video, but I’d prefer to save my RAM and get into the game quicker.

I don’t have that setting performed on TestLive, though as every time I try to make this change, I get a prompt soon afterwards for a (time) costly “Something is Invalid: have Steam Verify your files”.

The SSD will be a consideration when I have positive cash flow again. Spending less time with games will be required to achieve that end.

Make the game.ini change and start it from the executable in F:\Steam\steamapps\common\Conan Exiles - Testlive Client after starting Steam. That may work around any Steam checks. Your path will be different, but the file is ConanSandbox.exe.



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.