Venice Waiting Crisis


#1

If the helicopter is already there when you show up, you can’t take it. It isn’t “your” helicopter. Sometimes, it just sits there for minutes before despawning so you can summon your own. Though, sometimes running away from the area and back makes it leave, not all the time.


#2

I was rather wondering why the helicopter leaves in London, as opposed to one of the nine playfields that have a reduced player cap essentially to alleviate just this sort of issue, myself.


#3

I always wondered why the helicopter has to land right in the middle of the street in front of Templar Hall. Either way, this is just another annoying inconvenience to fix.


#4

This helicopter is not player-specific; anyone who is on the correct stage of the mission can use it. It should be present any time someone in the area can use it.

I can’t help but wonder if possibly you were on a previous step of the mission (did you read the SMS and listen to the phone call?) or if weren’t close enough to the helicopter cab.

If this happens again, a screenshot would be great.


#5

I was just coming here to confirm that it works fine for me if the helicopter is already there.

On a related note, could we get a teleport to faction HQ to cut down on the running around in these missions? :v:


#6

It definitely is noninteractable for me if it’s already there when I show up. Running a distance away sometimes causes it to fly off unless there are other people hanging around. If it flies off, I can run back to it and it flies back down and is interactable. I run the faction missions each twice a day given the 8hr cooldown. This happens all the time. It’s not a one time thing or I just forgot to do a mission step. This happens consistently.

I don’t know what kind of screenshot you need? It’s just the helicopter sitting there. Nothing special about it other than I can’t interact with it.

EDIT: Maybe related? The other day, I noticed a large phantom hitbox in front of the helicopter. Right up next to the red bus that’s directly in front of the helicopter. It was about the same size as the bus and I could walk under it, but I could not jump and the camera would not clip into the area. If I walked under it the camera was forced into my character’s head. I could jump at it from a distance and hit an invisible wall. I was going to make a report about it, but I forgot and then today when I did the mission, there was no such hitbox. I wonder if that was perhaps the helicopter hitbox? I don’t know. It makes no sense to me and since it only happened once and being invisible there’s no screenshot proof so… yea, that’s a thing that happened.

Edit 2: Well it just happened now, coincidentally.

Not interactable. No yellow outline. Smashed the F key until it fell off. Nothing happened. Ran away, it flew off. Ran back, it came back and was yellow and off I went to the rest of the mission.

Edit 3: Probably last one. I noticed something this time. When I ran off and then back to the helicopter, the mission updated from “Go to” to “Board”. Showing up while there is already a helicopter there seems to not trigger the mission to update.


#7

This is a problem caused by reaching the pick up zone before the quest has updated. If you are already in the zone the quest wont count you as having entered it and wont update to the point where it tells you to board the helicopter. This can happen fairly easily if you read the text in London as you can reach the mission area well before the phone call finishes and updates the quest. Best solution is to take your time reaching the pick up zone, or to leave the pick up zone and then reenter it to trigger the next stage. The area is also larger than that indicated by the red circle


#8

Actually, I start the voice message in Agartha right when I pick it up. As soon as I grab it I port to London. If I’m beating the timer and that’s breaking the mission then this is a bug and/or oversight that should be fixed. If I get to the spot before the mission updates then when the call ends it should see that I’m already there. This is a huge problem with missions in this game in general. The scripts are not very smart.