‘virgin’ installation of Steam first and the game fail to start with err 0xc000007b

Game mode: [SELECT ONE] Online official | Online private | Single-player | Co-op
Type of issue: [SELECT ONE] Crash | Bug | Performance | Other
Server type: [SELECT ONE] PvP | PvE-Conflict | PvE
Region: [ Please enter your server region ]
Mods?: [ Are mods installed: Yes | No ]
Edition: [ Select one: Steam | Microsoft Store | Game Pass | Epic Games Store ]


Bug Description:

After install Steam and conan exiles game fail to start with error code 0xc000007b. I know that mean a generic error with plenty of suspictious causes but:

The MS Store Conan exiles still runing friendly, (updating issues related in other post). That game tested after Steam, the new CE and so instalated, mean not look like a pissed off Dll’s or so, by the new apps added.

My W10 (64b) looks healty full updated (SFC… DISM) ok, NVIDIA last driver GTX 1650 ok, DX12 ok…

Thx in advance.
Raster.-


By 'new apps added" do you mean mods?

if so, some mods are out of date, try disabling them one at a time, if you do have mods.

hehe please read, virgin instalation apps mean Steam and CE, never started yet. The error ocurr few seconds after I clicked play CE.
Sorry if my english is not soo good people.

Thx anyway
Raster.-

it is probably missing a component, that won’t install by itself
since no data provided I’d guess it’s a VC++ issue

Try verifying your local files. Always verify local files after a large steam game installation or update. Steam tries to do this automatically with a new install, but it doesn’t always work.

Disable any anti virus to install conan exiles fresh.

If that doesn’t work, type sfc /scannow in command prompt and let Windows validate.

If that doesn’t work, do what drachenfeles suggested. It could be missing dependencies like .NET Framework or Visual C++ packages.

Hey Ty All guys,

I did all of thats verifications, but not added somes in the first post. the last was, enabling Net Frameworks 3.5 across Windows features, result with the same error at start.

Steam looks like a stand alone shell, cos in the common dist, use a vc++redist 2010 a bit more older then the one I have, and DX10, my machine use DX12 as well. My vc++redist includint 2010, 2012, 2013, 2015-19 last versioneds.

Maybe the ‘sin’ were install all the new software, mean Steam and game directly in disk E:? At the start instalation they ask where you want to install, and have not warnings or so.
I didn’t take a look yet about Windows environment variables. Perhaps some binding not added there, who knows.

Following the maybes world… I can try to uninstall all Steam, expand the C: unit reinstall there,and see the results.

Im honesty lost in the Steam world xd. Even a poor support of STEAM & FUNCOM.

But my CE via MS Store (without some limitations, by other error (MS / FUNCOM) still playable, without the 2.7 patch and an error in a new armory bench I added, described in my first post writen here in spanish language.

Raster.-

I would suggest uninstalling MS Visual C++ 2013 and performing a fresh install of it. You can also try launching the game with and without BattlEye from the local folder.

Hi and ty,

Sure I can do that.
A question by curious, why you sugest just vcc++ 2013? Mean you know CE use only this vcc++ libraries?

By the way my side customer still waiting some sugestions from any FUNCOM Tech.

Raster.-

because it’s micro$oft who puts those packages together and they’re helluva mess
fixing issues usually involves blind installation one by one sine very beginning, cause they casually drop thing or two between versions… with no documentation available
you install latest and end up missing some files, observe funny popups when running programs

HI all,

Im bored really, I refreshed all the set of Vcc++ redist. Forgetit, nothing change, still appearing the 0xc000007b.
There are bunches of documentation, but is so technical.
Plus classics errors about libraries, showns another kind of pop ups, usually. example: missing Xinput_3.dll or so.
I spend money to play friendly, but need to waste my time finding strange mistakes, No way.

Raster.-

that’s a thing when owning a PC either you fix it yourself or give it to workshop, just like with cars

ok, this is getting weird, how do you get so many missing libs? steam should handle those automatically, but that besides the point, this one is from DirectX, this should not happen even on clean install,
go ahead and manually install all from DX9 up

Check your Win10 system protection settings (Randsomware Protection) - Block History, look for a tab called Block History.

So, I have this same error code every now and then and it basically kicks me back to desktop. I found, what I think was, the problem. Perhaps, it might help. I don’t know, but worth looking into.

I have a Theron gaming mouse and have mapped one of the side buttons to use for Teamspeak communication. My game seemed to lock up when I used it during game or gave me that error when it was loading in, or somewhere in between loading and being in game. What was happening, is that Theron mouse control and mapping program, being on in the background, since it comes on at startup, was creating a situation where the game would lock up or give me an error in loading when I would key the side mouse button. It also would give me the symbol that it was changing the mouse DPI, when this happened. I solved that problem, by letting the mouse program go through its startup, allow it to load in the settings for the mouse and then before I opened TeamSpeak, I shut the mouse mapping program down. It seems to have solved my problem. Yesterday, I forgot to shut it down and as the game was loading, I went to talk to a buddy and it gave me that error code and shortly afterwards, kicked me to desktop. I shut down the program and then reloaded into the game, and it worked just fine.

This might not be your specific issue, but it is worth looking for a background application that might be creating some sort of issue like mine. Maybe, it is something as simple as what I experienced.

FIXED!!!

FUNCOM, PLEASE, do a simple (for your Tech people)detailed way to solve this kind of non-sense errors, please. Think about the customers.

Ok, let share what I did.

Of course I used first, SFC and DISM and all was with ok results.
After that all the recipes across internet, like AVG supression, Zone alarm verification, etc.
Next a reinstalation of Runtime Directx from June 2010.
All of this without changes.

Got a Procmon, and trace twice start secuences of CE.
I saw two strange events.
1.- CE tried to find a d3d.dll, that item don’t exist. Maybe a compilator
issue.

2.- Saw suspictious searchings about xapofx1_5.dll every time. Have not much expereince with Procmon, so I never saw the error cause good defined, but used that avaliable info.

3.- I verified the dll versions on both places windows\system32 and windows\syswow64, curiously I find the same version of xapofx1_5 in both directories, bad thing.

4.- Across the net I find only one well defined reference about this dll.

5.- I renamed both versions of xapofx1_5 and xapofx1_3, following the recipe.

6.- After that I reinstaled again directx June 2010, this time I saw the correct versions in every directory, 64 and 32 bits.

7.- I’ve crossed my fingers and yesss, It worked fine.

So, nor SFC or DISM had detected this issue. Even the first reinstalation of DX June 2010. Be carefull.

My next goal is get my game.db from MS Store CE and recover in this new CE changing the signatures.

You see @drachenfeles, some times I touch my car too!

Many thanks for all of yours replies and sugestions.
Raster.-

1 Like

glad to hear it

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.