Why do Things not Stay Fixed?

I have made two threads about this in the passed years, so I am not going to make a report about it. I am saying this because when I did make the threads, there seem to have been very little people who echoed my problem.

The problem being that, after a purge, I fix my damaged building parts, when I turn off the application and then turn it on again, what I had fixed is still broken, like I had done nothing at all. This happens to building pieces, mostly, rather than placables, those stay fixed.

I would like to know, how many of you does this happen to? Like how do your buildings or defences survive hard purges if nothing can ever be fixed? I cheated and put building damage to 0.1 because of this.
Or am I the only one who has this issue or something? Does it have to do with my internet connection or, I do not know. Only that, this issue has been with me since literally day one of me playing this game.


For me, it depends.
There is something of a hidden refresh timer in the game. If one logs out or closes the game between taking an action and that action being saved, it seems that the game “forgets” that it happened and reverts to a previous save state.

I haven’t seen this as much on the private servers I play on, but on public servers with a manky connection or in single player, I find it useful to linger at least 15 minutes after any major alterations and interact with them at least once in their repaired state, or wander away, out of render distance, then reenter render distance and check with the hammer.

1 Like

Things stay fixed as long as I do not turn the game off, but I will attempt to go away and come back again, then turn game off and on again, see if it will work


Good luck.
I hope it works for you.


If you think it’s an update-lag thing you can try other things that you think might force an update to occur. Moving a thrall position, picking up and setting down some placeables, adding a few arbitrary blocks to your base and removing them at next login, running your character far outside your base’s area and then back, etc.

I’ve not ever had this problem myself - or at least not that I’ve noticed. One thing is true, the repair hammer is a bit unstable. Sometime it tells me I’ve repaired something to 100% but if I check it a second time :watch: 3 to 5 minutes later, it shows that it was not in fact completely repaired. So I have developed the habit of hitting things 2 or 3 times “extra” and that seems to solve that.


I am willing to try anything now. Going away and coming back has not worked, but on my way back there was an enemy I had to fight which may have “interrupted” the saving? Ugh :tired_face:

Okay, so linger around then, and check with the hammer again, and hit everything even though it says it is fixed?

The only other thing I can really do is leave everything broken, and when the purge hits that area, I use the ten minutes to fix everything.

I am wasting so much material because this stupid crap will not save.

Hmmm, yeah, my dumb ideas were if maybe it was somehow not updating client-side. The block-states are kept server-side (at least on PC), and transmitted to you when you check something like with the repair hammer or whatever. When you repair something it should be updating the server’s DB immediately (ping time + packet transfer time + server file write time).

Anyway, that’s the full extent of my limited knowledge - not really enough to formulate a workaround. :stuck_out_tongue: And I dunno what else to try. Maybe others can think up some. Did you check the known bug-list for this - to see if it’s actually a thing or just on your system?

1 Like

Where do I find the known bug list? Also I am on single player, if this helps clarify some things.


Yeah, that makes a lot of difference. On a PC I would tell you to check file permissions to make sure it’s writable and so on. And also to make sure the HDD isn’t erroring out (at it’s relocatable sector limit). PS is just a computer but I dunno any of the maintenance options available or how to check anything. Others might.

In Single Player mode all the DB stuff is stored locally AFAIK. So the problem is likely with your system or it’s configuration in some way.

1 Like

A ps4 is not as complex as a PC not does it have nearly as many tweaks and options as a PC, but there is enough I can look into to see if it may be the problem.
But I just do not get it, why would the ps4 save everything I am doing in the game except for the fixing? So weird.

Oh but it does have a safe mode I periodically have to mess around with, when my profile, friend list and ps store refuse to load. Maybe I have screwed in it one times too many.

Am off topic at this point, but I have owned all of the PlayStation systems, and I do have to say, as far as performance goes, ps4 is definitely the worst of all four consoles. Cannot say anything about ps5 as I do not own it.
I miss how awesome the ps3 was haha.

1 Like

We still have a ps3. Have you tried turning off building damage

I turned building damage to 0.1, this is as low as it will go, at least until I find a solution for this.

Is there another option somewhere for buildings?

1 Like

I have not played offline much. On our server we can turn building damage completely off so it says starmetel drops tear the map room up north occasionally.

You mean that you can turn off building damage completely with the slider?

1 Like

One thing I found putzing around.
Pausing the the game and opening the admin panel (not necessarily doing anything, just opening it) tends to force a refresh for me.
It makes fresh bodies lootable as well, if you are having that issue, where you freshly made a corpse and it is not interact able.


This is in general settings. Don’t know if it will help or not.


I am very thankful for all the help and suggestions everyone. :purple_heart: Unfortunately nothing works, but that is not stopping me from enjoying the game.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.