Building repairs will not save

I have had this problem since I first started playing in April, and have addressed it three times, here and other places online, and not once have I received a single response. Which makes me think I am one of the only ones who have this issue or…there is something I really don’t understand.

When the purge hits my buildings, I go to repair them. When I turn off the game and log back on again, most the little hammer icons have returned. The repairs do not get saved. Almost. Say I have 20 repairs to do and fix everything, when I come back only two are saved. But the material I used to fix unsaved pieces is gone. I can’t just fix two pieces, turn off the game and on again, because then two or three pieces don’t save. It’s like the game wants me to mass fix things in order to save only a few.

I cheated and turned off building damage to 0.1. I want to play fairly and I don’t mind rebuilding or fixing, but I DO mind if the game will not work correctly. I have my main base by newbie river still so it doesn’t matter much, but because of this I’m afraid to make bases in better places with stronger purges because I won’t be able to fix anything. :frowning:

And yes, by turning off game, I do mean returning to menu screen, I know this is how the game saves.

1 Like

Have you checked each individual piece with the hammer. I have noticed when repairing I have to hit turn away and then look at the price again to see that it is repaired and the hammer icon removed. It could just be a visual bug that doesn’t register it as being repaired even though it is.

1 Like

There is a known issue with repairs not “sticking”. I find it happens most with stairs. You repair them, it shows them repaired and at full health. Leave the area, come back (so it reloads) and … oh, look, they’re damaged again.

So, yeah, it’s a thing. It’s been a thing for quite a while.

(I play on Xbox, not PS4, but I suspect the same basic problem is at work here)

1 Like

So it’s a known issue…I like how the community manager guys replied to like every single thread in this section except this one.

Hello @Alhambra, thank you for getting in touch, we apologize that we’ve missed your previous reports!

Although it’s a known issue, we appreciate that you took the time to provide us with detailed information and we’ll be forwarding it to the developers.

Do you recall if the pieces that did not save had their durability reverted to their previous value?
Have you tried to hit them with a weapon to see if they refresh their status correctly or do they always need to be fully repaired?

To conclude, which specific type of building pieces are not saving correctly?

1 Like

Thanks for replying, sorry for being a b…>_>

The materials in question are; sandstone foundations, fence foundatioms and stairs.
Tier 2 brick walls, doorframe, foundations. The door I was able to repair without it resetting.
Tier 2 insolutaed wood ceilings. Large Darfari wind chimes as well.

And yes, when I log back on, the value is still the same as before I had fixed it, I memorized a few to make tests. One thing I didn’t do was hit them again with the hammer, but without the needed material. I will try that tonight, see if it does something.

I also, ideed, hit the pieces until they get fixed, I am aware that you have to hit them head on.

On a slight note, repairing things this way is very frustrating because some pieces are hard to reach. It would be cool if, while fixing things you could just highlight the boken pieces, kind of like how you select spaces while building. Or have a fix all feature?


Fix all feature would be fabulous! Though I think the PVP community would :weary:

1 Like

Just to confirm, is the issue only occurring in Singleplayer?

Yes, (forgot to mention this) single player offline. I haven’t tried other modes at all yet.

1 Like

I’m curious to know, for anyone who does have this problem, does it occur on other modes besides offline? For some reason I can’t find anything at all about this on the internet.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.