Xbox (beta) PC - Mutant Year Zero crashes when starting up

Hello, I’m trying to play the game on my PC (I also have the game on my Xbox, also thru Game Pass) and it crashes every time I try to start a game.

It goes thru all the title cards, and opening cutscene. Then you get the screen that says"Hit button to continue." I do that, and it says “signing in” and then crashes to desktop. Every time.

Have tried reinstalling and rebooting with no change. Other suggestions?

2 Likes

Exact same issue here as well.

Xbox Game Pass on PC, game crashes when Sign In comes up. No UE error box or anything just drops to the desktop.

I have also the same problem, does anyone know hot to fix this

This has been my issue for days and days… I have tried so many different fixes… I can play any other Game Pass game, no problem, but this game won’t let me sign into xbox live…
On the other hand, the Mutant Year Zero DEMO on GOG played JUST FINE…
Here I am with full access to the game, and can’t play it at all…
I’ve tried contacting Microsoft support, guess what finally happened after trying to get ahold of a human for 2 days? They told me to get in contact with the game developer, because it sounded like a problem with the game itself, and ENDED THE CHAT…
This is ridiculous…

1 Like

Hey,
Open Xbox game pass and click the profile option at the to right > settings > account > sign in

Hope this helps. The dev has given horrid support regarding this issue. That’s why I haven;t purchased the game and am simply trying it out on XGP.

Cheers,

Sorry, I don’t understand what you mean. I’m already signed in to Game Pass when this happens.

I followed your steps and I get a screen that shows my logged in profile and “Edit” and my XGP subscription and “manage”.

I had the same problem until I noticed a message on the launch page about using Administrator mode. I closed the XBox app, ran it as an administrator (Right click on the app in the Start menu, choose “More”, then “Run as Administrator”) and now it works.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.