Xbox One...Can’t Harvest Corpses

I’m level 12 and cannot harvest corpses. The icon to harvest appears, however, I can find no way to harvest. I’m sure I’m missing something. Any ideas?

Gotta give us more info.
How are you trying to harvest them? Are you using a tool?
What’s happening when you try?

If you’re level 12 you’re best tool for the job is gonna be your stone hatchet I think. For some creatures you’ll have better drops with the pick tho.

I don’t remember what level you need to be to get the iron tools offhand. You can make a skinning knife and a meat cleaver once you unlock that.

Also, all the religions have a special tool for harvesting a specific thing from NPCs for crafting at their altars.

Hi, I tried to harvest using a sword and the daggers. I admit I haven’t tried with the hatchet or pick. When harvesting, what button do you utilize? One of the attacks, or the X button. Nothing I tried works. And Lord, building with the controller is an extreme pain.


Worked with the pickaxe. Thanks.

Either attack button works. Different tools will give you different results with each thing you can harvest. Do some experimenting. (Hit a tree with a pick to get bark for example. )

There’s a bug with the building that they’re working on…

Thanks guys. New to the game, and so much catching up to do. Hugely appreciate the help.

You’re welcome. :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.