Xbox One digital copy not downloading

Hi, I am new here but just wanted to see if anybody has any advice with this issue I had.

Yesterday I bought Conan Exiles on my Xbox One mobile app and pushed it to download on my home Xbox while I was out. When I got home the game had not only not installed, but was also nowhere to be found in the ‘Ready to Install’ or ‘Queue’ list. When I checked on the Microsoft Store it said ‘You own this product’ but gave me no option to launch or install.

I called Microsoft support and after an hour trying everything they gave me a refund and cancelled the order saying maybe try it again and see if the issue persists. Low and behold I tried again with exactly the same results and I had to get a second refund.

I really want this game and I know I could buy a physical copy but would much rather have it digitally. Has anybody else had this issue or knows about a fix?


1 Like

Do a hard reset on the Xbox and try to order it through the Xbox instead of the mobile app?

I have not had this issue but thought perhaps this could help.

I had to hard reset the Xbox to gift conan to a friend

1 Like

hey i am having the same problem and i have contacted microsoft too, they said they will solve the problem in 5 days… i really want to play too, maybe their servers are down?

I would highly recommend takin your refund and buying state of decay 2, that will fix all your problems and prevent future issues and frustrations

But also provide nowhere near the same experience :thinking:

1 Like

I have the same problem. Do Funcom know when can we download the game?

Having the same issuse as above. There is nothing on xbox support about this and the only information i have found seems to be on this forum.
The game itself has not install but the free nudity DLC has installed. The game is not in the list of games that i have bought or in my list of games i can install.
Tried a hard reset and it didn’t work.
Can someone please look into this.
UK based

I also am having this problem currently contacting Xbox just now but does anyone have any advice

Just contacted Xbox and the said a lot of people are experiencing this problem and they’re trying to fix it so. Basically just have to wait for it to get fixed

Yes I tried it twice, once on mobile app and the second (after a refund from Microsoft) on the Xbox itself. It still did not work so I got a second refund. What a shame. Hopefully this will be fixed soon and I can try again.

I had the same problem but it’s turned up in my ready to install, i left my xbox turned off and went to work, came back and it was there

Excellent news, when was this?

I can confirm this seems to be working again now. I have just purchased the game on the Xbox store and it is currently downloading to my hard drive :+1:

Would have been midnight going into saturday for