2.2 Patch Lag and Performance Issues Troubleshooting

Many of us are having severe performance issues since 1/6/2021 2.2 patch, making the game virtually unplayable. Funcom has acknowledged the issue and says they are working on it, but it’s taking a long time. The issue is not universal, since some people report the game is running fine for them. Is there anything in the meantime that the community can do to help troubleshoot the issue?

As for myself, I tried the following to no avail: running with and without mods, changing graphic settings (low to ultra), restarting computer, killing background apps, updating video drivers, and running other games to see if they have issues. I haven’t reinstalled the game yet. I noticed the lag gets worse with thralls, or in my base around buildings, containers, etc. Running around the world alone is still laggy but better. I am running on an Alienware Core i5-8400 CPU @ 2.81 GHz, 16 GB RAM; NVIDIA GeForce GTX 1060 6GB. If anyone cares to share their setup and if they have problems or not, or if anyone has had any success in troubleshooting these issues I would greatly appreciate it. Thanks!

4 Likes

What kind of ‘lag’ are you talking about? Is it Framerate loss (stuttering, slideshow appearance), or is it latency based (rubber banding, doors/chests take a while to open sometimes)?

There’s a ping issue that causes a ping spike once in a while, and that is affecting everyone. From what I understand, that’s what’s being fixed.

1 Like

I was running this game on ultra without any troubles and with stable 60 fps be it pvp/dungeon or just running around doing random things.
After last update my client side fps drops to 20 or lower every time some kind of npc goes does something close to me or just by running around.
It even worse if I open admin panel.
There’s no server side ping or lag issues from what I see.
Just client side fps drops.

I have the same problem after the update. I have an observation, my HDD lights up and it appears texture updates during the lag. I’m wondering if those who are or are not experiencing this have the game loaded on a HDD or a SSD?

it’s stuttering and freezing. I am playing on single player (offline).

1 Like

Mine is loaded in my 2 TB st2000dm001 HDD

1 Like

Are you on a Laptop?

Your hardware seems fine enough to run the game fine even on higher settings. My concern is an overheat issue, some laptops don’t vent heat well and even though the parts inside can run a certain load, if they can’t get rid of the heat, they will scale back suddenly.

You’ll need to run some sort of monitoring software and see if your CPU temps are going above 80-90C. That could give us more to work with.

Have you ever tried to install an NVIDIA GeForce GTX 1060 6GB on a laptop? Probably not…He is obviously on a PC tower. I run a Radeon RX 5700 XT which is the size of a small city.
Captureradeonxt.PNG

Still the overheating is a valid issue and a good point with Alienware.

2 Likes

Yea, it’s a big ol’ tower. I don’t think it’s overheating as the fans don’t work very hard during this game, and it still runs like crap on the lowest settings. However, like someone said before, I do notice a lot of HDD noise, maybe it’s a texture loading issue?

1 Like

If you don’t mind as some games I have run bad at certain times but do you have windows if so go down to your search bar and type in virus & threat protection click on it and disable real time protection

Due note on windows 10 pro if that helps there is a way to disable permanent but on no pro you can but for me it would not and the real time protection will turn back on after about 2 hours or on restart of pc

Ps this helps all games I have in performance dramatically and is not tied to this update hope that helps as I don’t have ce on pc just Xbox

Two things you might try, increase the size of your paging file (system, advanced system settings, advanced) and check the game for corrupt files (steam, Conan Exiles , local files , verify integrity of game files ) Your hardware is very capable of running this game in ultra without issues.

Im getting the same issues with lag but its mostly stuttering issues and sometimes rubber banding. Not sure if its connected to the same problem, but my thrall seems to stop following when doing a Vault (Isle of Siptah)

I have a laptop with a GTX 1070 in it. They literally build laptops around fullsized cards now (or have been, mine is over a year old now). Which is why I asked.

I can vouch for the heating issue on laptops throttling performance. Using an i5 core and a GTX 1060 in my laptop and the heat can definitely flare up quite a bit. Picked up a cheap cooling pad and I must say it has made a big difference in the heat buildup, which in turn has increased the performance slightly. Obviously this is not the solution to everyone’s issue but it sure has helped on my laptop anyway.

So the laptop version of the GTX 1070 is flattened out with no fans. When you say full size its confusing.
Captureaery ngu.PNG

I tried this to no avail. Files were clean. Also, to update on the situation:

I experienced the same performance issues on the Siptah and Exiled lands map. Someone said it was an exiled lands issue, it isn’t. I also started a brand new game, and no issues! It could be something having to do with the game/server file size or stuff you build. My new character doesn’t have much yet, no buildings or containers, just a campfire and a bedroll and a few items on the inventory. I would continue to troubleshoot, but it seems that Funcom has found the solution to the issue and is issuing a hotfix next week or so, therefore I’m done experimenting. Thanks to all who tried to help!

2 Likes

I played an existing game , and have started a new game. Same issue since the update. Huge FPS drop. It does not matter if your setup is 60 FPS or above. This occurs randomly . The odds go up where there is a hit such as flames in general or your movement is increased. I have performed tasks similar to the ones posted here. I have stopped playing the game . My rig is a tank and everything is as it should be. The FPS drop causes the game to stutter/ stop.

So is your bad game performance the same in the new game vs. the existing game? My existing game is a slideshow, but I could play a new game just fine. That is until I started building things up; I noticed performance starting to slowly drop. It has all the feel of a memory leak somewhere in the stuff you build. Good thing it seems a hotfix is coming next week.

I have the same problem, since the last update the game is practically unplayable, in a normal game “vanilla” it goes wrong, but in my game with mods it is horrible, you can’t and it doesn’t matter if I go from ultra to low, it’s still the same, the workload of my graphics card rises to 100%, my team is the following and the worst thing is that I have a series on youtube and I had to leave it for the moment because it is impossible and if it is true, in my base unplayable and with my thrall gets even worse, nothing can be done.
AMD Ryzen 5 3600 6-Core Processor 3.59 GHz
Ram 16.0GB
GTX 1660 S 6GB

Yes ,the game loads normally but as I mine for coal or any other items, 3 or 4 swings in the FPS drop hits 0 for a few seconds. Building placement is unplayable . I have not re installed the game yet . I have 800 plus hours into the game and usually these problems are corrected in a short period of time.