Input needed: latest patches adding unplayable lag

So, I have been playing this game diligently since initial release on PC. I’ve been through the good, the bad and the ugly. Now, I’m playing on a self-built PC that I made about a year and a half ago with specs far above what Conan requires. However, I’m stuck playing on DSL internet because of physical location.

This has never been an issue when playing the game in the past. Basically, my PC is the only client using the Internet. And I frequently steam music or Sirius XM while playing. Now, however, since probably the last DLC patch came out, I’ve been getting unplayable lag in the game. I first started noticing it when things loaded in slower, sometimes taking 5 minutes or more for the surroundings in my base to fully render in. Worse now, I can’t fight at all any more. My stamina bar does not drain or refill like normal any more. It goes down in chunks that are delayed by seconds each so I’m never really sure where exactly it is at the time. And I can’t fight 1v1 in pvp or PVE any more. A trivial task like farming hides in the savanna has turned highly dangerous because I can’t anticipate attacks any more. And the combat music continues to play long after whatever I’m fighting is dead.

Now, I was planning to create a bug report as with the last patch there was a note about them trying to reduce the lag some were complaining about. So I’m assuming I’m not the only one that was affected? And the patch did very little to help, save tweaking how things load in when I’m first logging in.

I was hoping to get some feedback from others and see if anyone else is experiencing this. I’ve ran tests on my connection speed and it’s directly on par with where it’s always been. I run antivirus and anti malware on my PC and nothing else is using resources when I’m in conan. I’ve even switched from wireless to a direct connection to my router and nothing has made the slightest impact.

I’ve been playing this game for so long, and this has really put the nail in the coffin as the game is almost completely unplayable for me now.

Am I alone in this???


Well, judging by the lack of responses I doubt this will get fixed. Which makes me real sad because I’ll have to move on from Conan after putting so much time in.

I had decided to pull this game off my high end gaming rig just prior to this update. I was and had been having enough problems with it since day one with a computer that’s far above the system requirements for this game and I figured the latest patch was going to do what the rest have…cause more problems than it fixed. I hate being right. Two of my friends who still have it on PC have reported the same issues as you plus a couple more. You’re by far not the only one. I just keep my eye on the forums now to see if anything is actually getting fixed enough to bother reinstalling it and will continue to do so…at least for a while. I really had high hopes for this game when I got it in early access. Lesson learned.

I’d say both. The issues in this game have always seemed to affect some people more than others to one degree or another. And, yes, there are those who do minimize the issues quite a bit.

I’ve read a lot of forum posts on this forum and others such as Reddit and Steam…etc. and there are a lot more people experiencing performance issues with this game than some folks would care to admit. To show you guys that you aren’t alone, here’s a link dated December of '18 from these forums and here we are almost a year later still taking one step forward and three steps back.

1 Like

I’m Nubio101: Everything I said is true; My base disappeared after being absent for only 3 days, when I arrived there was no construction, only slaves and pets remained. Play station 4 game, in JcE- Conflict, on an official server (# 3051 PvE Conflict

Nice to see you again, @Ruinous! Sorry it’s under these circumstances.

I’m going to hit up @Maedhros, who elsewhere reported similar behavior, to disastrous results. Let’s see if we can’t get this stuff fixed.

1 Like

My home’s playing environment is connected to the Web via aDSL. I get max 8 megabit down, 680 kilobit up. That’s with a k, 0.68 megabits upload. If I didn’t run a router that supports upload QOS, our entire network will come to a standstill if I’m sending so much as a high-def screenshot.

Because I also have a 200Mb synchronous connection at the office, I can see vast differences in play experiences, both on the PC and PS4. I’ve got really contrasting information, and through other players’ interactions, I have learned there is somewhat a continuum of experiences with regard to Internet connectivity alone.

Two requests, please: a) run a speedtest and let me know your download and upload speeds and b) record and share a small video of your problem loading and rendering, with your DebugHUD up.


QOS is Quality of Service. If you have a router or WiFi hub that supports this, you can implement it to limit the traffic in certain instances so that the bandwidth isn’t starved by one client, one operation, or even one particular IP address.
DebugHUD. In Conan Exiles, hit your Console Key ~ tilde key by default, and type toggle debughud and press Enter. You should now see all the session vitals in the upper right corner of your screen. Hit Esc to leave the Console mini-screen.

1 Like

Not all the time, but many times this is caused by background applications and downloads occurring while in-game.

Especially around crucial windows updates.

1 Like

I would comment, but as of yesterday my server is down yet again with the same issue from July/August so I can’t speak to the performance currently. I will say that I’ve got a 100/40 connection, my ping prior to the July crash was usually 15-30. Once it was fixed in October the server ping is consistently 180-220.

As far as the stamina, attack animations, etc, when I see it I’m reminded of early Rust and the desync issues. So the connection is still there, and it doesn’t feel like lag when you play. Happened to me last week during an attack and I ended up running off my wall in full gear and falling to my death because the desync decided to suddenly fix itself after it was too late.

The loading and rendering takes a long time, I usually log in and then leave my character standing for 20-30 minutes. Then exit to main menu and reconnect, I often find that the server seems more stable on the second go. I think a 3rd of my recent hours have been AFK standing in the base while the game figures out what is where. I would try that, log in and hang out for a bit, then relog and see if it has stabilized. You can usually tell just running around your base, at least as I experience these issues.

Thank you for the reply and assistance. I’m off this weekend and will get the requested items for you then. I’ll reiterate though - we have two separate DSL accounts at the house on different phone lines. One for everyone, and one strictly for my desktop PC. It’s wired directly to the router now, and I even turned wifi off for the sake of argument. This issue is occuring constantly, not just intermittently. It doesn’t go away when everyone is in bed or at off-hours on the server.

Something I’ve noticed that just started happening when this issue popped up is that when I first load into the server select screen, my favorites pop up with 200 to 300 ping at first. Every time I refresh manually after that, it drops down to where it should and normally would be, around 50-60 ms. I can spam refresh over and over and it never jumps back up again. I’m not sure that this is important, but it definitely never did this before unless I had left something substantial going in the background, like a steam update or a streaming video. This is the type of lag it feels like I’m experiencing in the game and I dont understand what could have changed to cause it, other than something in the client. Perhaps something that was changed in anticipation of mounts being added?

This isn’t a graphical issue. This is definitely a connection issue. It’s clearly visible when I watch my thrall try to follow me around.

I have no hope of defending myself in pvp right now, which is super depressing with how much time I’ve invested into the server I’m on.

Great feedback. I think based on your reply there’s no necessity to upload video at this point. What would still be helpful is the speed numbers for your office DSL and a separate figure for your home DSL.

Are the two routers in any way on the same network? My concern is network segmentation, which can often create ancillary bottlenecks such as you describe. If the two nets are isolated, please move on.

If you can find the IP addresses in your list of favorites, it would be extremely edifying for you to attempt to ping them manually. I suggest running CE in windowed mode, and the moment you see the Favorites pop up with a high ping, press enter on your MSDOS-window ping to one of the addresses. Furthermore, any additional ping data you can provide would be helpful. Lastly, please try a tracert to your one favorite server – it is possible the DNS rules were changed, and your route is compromised. In this case, I’d ask you to flush your DNS cache.

I’m pretty sure you get the picture. :smiley:

1 Like

Both routers are separate. Everyone in the house connects mostly wirelessly to the one. And I connect hard wired to my own. They are separate DSL modems with routers built into them. We don’t have any need for an all-encompassing network in the house so they’ve always been seperate.

Watching my system resources during gameplay, the only processes that I see using the network connection is conansandbox.exe first and foremost, then occasionally steam client bootstrapper and kaspersky antivirus. Nothing out of the ordinary there.

I’ll post speed test results tomorrow when I’m home. And also test playing on the other DSL line while everyone else is out of the house… as well as test playing on another server.

1 Like

I had a feeling you know what’s up with your systems. :+1:

If you don’t mind disabling Kaspersky and enabling Microsoft Security Suite/Essentials for a short time, it might also help. Don’t want to throw another variable in there, but if you’re running Win10 there’s a possible hook in Kaspersky if you’re not patched to the latest Win10 release 1903 .NET framework.

Hit your Start Charm, type Windows Security and click on the app that appears at the top of the window. Click Virus and Threat Protection, seek the section “Who’s protecting me?” and click Manage Providers.

If you’re running Win10 Pro you should be able to delegate new providers. Select Microsoft Security Suite/Essentials and Windows Firewall. If you’re running Win10 Home, you’ll need to manually turn off Kaspersky, reboot, then select MSE and Windows Firewall as your providers.

ETA: after you reboot once Kaspersky is switched off, you may be put through a series of Windows Updates that were likely precluded by the security suite. I suggest going to Windows Update and forcing a manual check for updates.


Alright. So a couple things.

First, I completely disabled Kaspersky and Malwarebytes and still maintained the same issue. I have not tried re-enabling the windows virus protection and updating yet, but considering what I just discovered I don’t think it will matter.

I primarily stick to playing on the same server. I’ve been assuming that this issue was game-wide, however, I just loaded in to one of my other favorite servers and the lag was completely manageable. Npcs weren’t lagging all over the place while they chased me and my stamina bar worked fine. I logged back over to the original server and still had the same problem. So, somehow it’s server specific between those two.

I ran a tracert and will send you the results privately. It didn’t look that unusual, however there is a different 3rd step between the two severs I tested. Same base IP but the last number is different, despite the fact that everything else in the route, minus the final ip, is exactly the same for both. I don’t understand why it would be different at that hop, but in any case, I flushed the DNS and the route remained the same to both servers. And the lag continued on the one when I logged back in after flushing the DNS cache.

Just spit balling here, but could the amount of building pieces that I own on one server versus the other affect this? Granted the issue is server wide and not localized near my buildings, I do have quite a lot more built and claimed on the server I’m having problems on. I don’t know if that has any affect or not… but it wouldn’t surprise me considering they just tinkered with asset loading priority with the last 13gb patch. My base loads in way slower and things like doors and thralls don’t pop in to the world til I get very close to them.

I will also send you the results of the speed test, but I can tell you it’s consistent with where it’s always been.

About to try the other DSL line to see if it makes a difference… I’ll also log into a brand new character on the problem server using a family members steam account to test the theory about more property = more lag.

Well, I just loaded up on the “family” DSL line and
… zero issues. My base loaded in 5x faster than while I was on the other line, and no hint of the other lag issues I was having. Having done a tracert to both favorite servers while on this DSL line, the route to both servers was identical as suspected (minus the final hop to the official server ip) , however the route was different than BOTH routes it took while I was on the problem DSL line. Again, I’ll send you all of the tracert results privately, but I’ll don’t really know what to do from here. The DSL phone lines come in to the same house and are through the same provider, I don’t understand why the routes are different or what I can do about it.

Perfect. Since we’re communicating privately about your private digits, I’ll just fill people in relatively generally.

When Connection #1 tries to leave the private portions of your provider’s network – at the outer perimeter – there is an address that is likely causing a hold-up. While it’s a perfectly valid portion of the chain, there is a problem with the provider’s DNS server’s records that unfortunately put your machine through a few steps during the reverse lookup process. As I said privately, I would contact the provider and ask for another gateway, or if you may use the gateway from the other router. Because your external (real world) IP addresses are significantly different, I wouldn’t change this without their approval or blessing, due to the likelihood of further recursive morasses.

Glad you’re back in it!

Wait, the latest patch could have been it too?

And I was thinking it had to do with the many mods on my server, guess the problem overlapped somehow.
Will dig through the info here and see if I can get anything working that way.

Sorry for not keeping this updated here. My issue ended up having nothing to do with the game. It was just bizarrely coincidental that it started to occur around the same time as the last patch.

I owe a huge debt of gratitude to @Barnes for helping me troubleshoot my connection, as it turned out to be an issue with one of the servers that I get routed through from my local IP. Thankfully I could switch to the other DSL line and continue playing without issue for the time being due to having seperate IP and Gateway addresses on that modem.

Good luck to anyone else having trouble, Barnes is the man!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.