Able to log into game, but not account page

Just what it says. I can log into my Froob account in game, but I am completely unable to log into Anarchy-Online account page.

I was considering reactivating my account because nostalgia, but it’s impossible. I changed my password successfully, but am still not able to log into my account page, only the game itself.

Your IP is being block on the AO Account webpages. It happens after logging into the ao account website several times in the same day. You need to wait a day or more for it to be unblocked.

Block IP - Work Around

  • Wait a week or maybe a day for the hidden block to be lifted.
  • Connect computer to another internet access point. Try going to a coffee shop or library and use their internet connection. Maybe use a friends smartphone hotspot.
  • VPN can be used if you have access to one that allows connection to gaming sites.
  • Use your Smart Phone or Pad. Turn WIFI off on it, so it uses its cellular data connection. Then connect to the website.

To prevent your Froob account from being disabled you can submit a /petition requesting your account not be be disbled every month.

I tried to log in from a different IP just now on my phone from my cell carrier and it did not work still. Even tried a VPN and it just keeps telling me " Authentication failed, please check your password and try again"

You can try an alternate site https://register.thesecretworld.com/account Use your Anarchy Online account and password.
Once you connect, on the left side is a HOME button under My Account. It that takes you to an older Anarchy Online account page.

That also did not work. I sent support a message, but have not received a response. Pretty frustrating, but I guess they don’t want any of my money.

If your able to log into the game. Send a /petition

You can also ask about your problem on the Anarchy Online MMORPG Official Discord

Yeah I tried that as well, no response. Seems AO support doesn’t exist anymore.

If you are able to log into the game with your account.

Are you a Paid or Free account?

What are you trying to do on your account page?

I linked all my accounts to a single account page a long time ago. I have a couple paid accounts and free mixed. I can obviously only log into my free accounts in game, but I can’t log onto my account page at all, using any combination of names/passwords.

Had I been able to log into my account page, I was actually thinking about reactivating one of my paid accounts and having some fun.

I’ve never linked all my accounts to a single account page.
I dont know if trying forgot my password would work on the single account.

I did it for a few froob accounts but I waited a few weeks to make sure the IP Blocker was not an issue. Somehow the process I did seem to use TSW and Conan screens to get it to work. It was a pain and I got lucky.

I did some more research on Master accounts. I do remember them but did not use them for several reasons. I found they are no longer an option but it seems some people on Discord are still able to use them.

Have you tried connecting to the sub-accounts using the Account pages?

I can’t get into any of my accounts, at all. Not even my Froob account that I can log in game with. I tried a couple of different VPNs and using my phone as well, and nothing.

Maybe create a new account and make sure that works. Then create a new toon and just leave it in Arete unless you want to use it. The good thing about new Froob accounts they dont seem to get frozen by Funcom, their expiration date gets set to the next year in January.

On Discord, you can try to message the support person when they are online. Sometimes they chime in when problems are discussed.

I can’t seem to make any new accounts, either. Even using a different browser. I don’t know what is going on.