Can't log in to account tried password resetting and following the forum but no dice

Followed the forum post on how to recovery your account and log in to change your game accounts associated but does not work. Oddly enough i can go into the game and when i reset the password the new password works in the game just not for the account. Gives me the you have no subscription error which is what i was trying to do is reup a sub. I cannot seem to get into the actual account page though.

Well tried again yesterday and again today same issue. Authentication failed, please check your password and try again I reset the password for one account again and followed the link back to the site which then tells me i am using the wrong password and gives me the link to change password yet again. Endless loop. I can use that password in game however to log in, just cannot get to the account page as the password still does not work there. I have 4 accounts and all have this problem now. Can log in to them in game but none can be accessed via the anarchy account page, which makes reupping a sub or halting a sub impossible.

Tried creating a new account as well. Register the new account, windows asks if i want to save the password i say sure. Then i log in with the new account and password and get invalid password or user name. So not sure what is talking to what but i can’t even create a new account it seems.

have u tried with: ?

yeah no luck

Honestly have given up, i just want to be able to log in now to disable my auto renew on a few accounts so i dont have to charge back every month.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.