AI not responsive, Thralls bugging out

Game mode: Online private
Type of issue: Bug | Performance
Server type: PvP | PvE]
Region: UK


When fighting the AI they do not aggro, and if they do its sporadically. The thralls are not attacking either and are getting lost/teleporting/stuck.


Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Fight/go near an AI
  2. AI doesnt respond
  3. Thrall doesnt respond
  4. Thrall may get stuck, AI may teleport.

I do run mods, however it doesnt appear anyone else who runs these mods is having the same issue from what I can see? Just curious if anyone else is, would like to narrow down the problem.

Cheers

2 Likes

Huh, sorry. I didn’t see u are the same person from the other thread. Check for mods that add custom animations and weapon combos such as EEWA, AoC, etc.

I confirm the same problem. Playing without mods on oddicial servers.

  1. Combat AI
    Thralls and enemies bug and stop attacking. Shielded enemies still get permanent resistance as they are keeping shield up even though it’s not true. The only one person who can attack permashielded enemy is my thrall, who is…

  2. …ALWAYS STUCK
    Thralls stop to move spontaneously. They usually get stuck near buildings, rocks, even in the middle of a place without any traps. Even if the thrall moves to attack, he returns to the position he stuck at. Even if I pick him up and place in guard mode, he returns on that position (I must run after him to catch). This thrall stucking remains till I use cartographer (he teleports to me and RUNS on the position back lol). Thrall doesn’t follow me even on a big distance, shown on the screenshot.

This stuck bug was reproduced by multiple players on several servers, I saw this bug a lot of times on my thrall and husband’s.

The stuck thrall, stopped to attack or move, has following mode:

I am FAR from him, he doesn’t teleport after me

He is running like crazy from the Black Keep obelisk back to Asagarth where he stuck at

1 Like

I have encountered same issue while fighting the “eggplant” boss on Siptah and on Exiled Lands while fighting enemies that are able to Knock Down my thrall.

My guess this is happening because thrall cannot come out of the knockdown Animation. I usually pick them up and move them, once i do that they Resume their attacks. Also After i move them their First move is to rush back to the point where it got Stucked First time, usually it comes back After a few seconds.

One more example of the place the thrall usually freezes at

The trick with picking up won’t work in such places as dungeons PLUS we have ‘cannot place’ bug :smiley: Was it supposed to be a bug fix update?..

Aaaaaand now the trich with cartographer doesn’t work either, look, I’m at Ymir Forge, and my poor Teimos is still chilling with nordheimers

1 Like

Thralls are getting stuck way more often now, it’s really frustrating.

3 Likes

I’m having the same problem here. PvE - Before the update my thrall was pretty active and aggressive. Now about 5-10 seconds into 70% of fights, a 2v4 becomes a 1v4 where I get surrounded and stunlocked to death and my thrall stands there in open ground unmoving, waiting for their own death after mine.

1 Like

Since the latest AoC update, animals have started to respond, for me at least.
Please verify it works better for you now.

AoC update 9. jan.
Changes & Fixes:

  • Fixed an issue with unresponsive creatures (Thanks to Hosav!)

Its also my experience that thralls do not attack if the creature is non-responsive.
That could be part of the not-attacking problem, but not all.

I noticed the same problem.

Before the latest update it wasn’t perfect but it was still manageable.
After update it seems I’m getting all the bugs that were supposed to be fixed and that I didn’t have before :

  • pathing issue
  • unresponsive thrall
  • thrall stuck and not teleporting

Overall their AI got worse, my thralls got so much dumber I nearly lost a purge thrall fighter to low level NPCs for the first time in 2 years.

Also, the NPC aggro was tweaked so that they don’t change their mind too often. Well, now they’re a bit too stubborn killing their chosen target. I can bleed them to half their health they won’t leave my poor mount alone.

2 Likes

I have this too ONLY after the Jan 6th patch. Game was find (AI + Thralls) before that. Now enemies agro but don’t move. If I get within melee they may attack. If I stand back and arrow them they seems to fall below the floor and become untargettable… Game is basically unplayable right now.

New AI is a disgrace. I rejected to go anywhere with a thrall, it is unplayable. I’ve made some screenshots and descriptions in this topic, and this happens every 1 hour, I’m sick of getting my thrall out of stuck position.

Moreover, enemies can stay and aggressively look at me for 10+ seconds without moving. Shield bug was not fixed. I can’t imagine how this update managed to go live, if I would do my coding job with such amount of bugs and errors I would already be fired

1 Like

Yeah, did anyone play-test this change at all?? The aggro logic before was very erratic (actually really funny and perhaps appropriate on hyenas), but at least I could get aggro by getting in range and then my thrall could take aggro off me. Now mobs see me and are dead set on killing me to their last breath regardless of them getting their brains smashed in by my thrall.

2 Likes

My horse is the new tank, especially vs Beastmaster Teimos. All of the 11 times I fought him, he was only attacking the mount while my thrall and I were knocking, hitting, bleeding him.

I encountered this bug r ight after the leveling system update, but haven’t had any issue for months, I thought it was already fixed. Now it’s happening again.

Same.

The leashing bug is also new to me, never had problem before this patch. Now I get random NPCs chasing me to the end of the Exiled Lands while my thrall is still stuck in rocks on the other side of the map.

Imma take my annual break from the game until it gets better :sob:

3 Likes

Any updates on this? Its been 5 days and no news… Still having thralls bug out/get lost/be unresponsive and the AI is bugged still…

Hey there,

We’re aware of this issue happening on modded games and it’s being worked on at the moment, with a workaround in place (discussed in the modding Discord).
If this is happening in vanilla games, we’ve sent notice to our team to see if we can reproduce the problem on our end and address it.
Thanks for the feedback.

2 Likes

hi! i’m having this exact problem, and you mention a workaround being discussed in the modding Discord; any chance you could link that Discord here? It’s making portions of the game unplayable and also making me very sad. :slight_smile:

Might want to check the Mounds of the Dead if you’re looking to replicate it. There seems to be a lot of sticky points there in particular, at least in my case.

Vanilla, no mods, official PvE servers. Me, my husband, all from 1300 and 1018 servers have encountered this AI problem

it happens in vanilla game to, ia is not working well at all for ia they stuck in lot of situation due to ground or npc.

Guys, there is a solution that may help the developes:

  1. go far enough, better use maproom
  2. command stop
  3. command stop again
  4. command return back

80% thrall will unstuck and return back

1 Like