Anarchy Online causing random pc freezes


#1

First of all ive played on and off for years since early release, more after 2005. I think the issue started around april 2018, i am playing with the old client, ive had this PC since a year ago so it didn’t do it at first.

First i thought it had to do with having more than one client open at one time but it keeps happening as randomly even with one client open, i don’t do anything specific when it happens, just slack in ICC or possibly do a xan raid or an inferno mission.

This kind of stuff don’t happen otherwise at all, not with any game, my pc has sometimes ran for days no issues before i shut it down myself, with Anarchy Online it happens nearly everyday i play, atleast once.

I am playing on Windows 7 latest version, with Core i5 3570k, 8gb of 1600mhz ram and an nvidia 960 2gb version, my client is installed on my second hard drive, not the SSD that has windows on it, i haven’t played on new client to test if it crashes my computer as well due to the other issues ive ran to with it in the past, for example the countless client crashes.

Now i know not all of the info might be relevant but anything might help in the end, also there is no error about it in windows logs, other than the forced shutdown message which automaticly comes when my only option to temporarily fix the problem is to shutdown my pc, how it happens is that everything just stops, images on the screen, mouse, pc becomes totally unresponsive until forced to shutdown. Ive tried alt tabbing, control alt delete spam and all kinds of things i could’ve thought of.

I understand that the game is old, not fully working with newer parts and stuff, the reason for this can be one of many, but if there is anything that could be ruled out to see if there is any change, would be great.


#2

Try playing in window mode, borderless


#3

Try
Old engine

New Engine

Through a system lock is unusual, AO will punish an i5 if it’s running in software mode (not actually using the GPU) .
All that said the old engine ran on single core CPU’s back in the day when 1ghz was super high end as was 512mb of ram, however the typical OS was much much lighter.


#4

Of course i didnt remember to give all the info even with all that, im playing windowed but i didnt remember you can have borderless mode on ao, ill give that a try.


#5

Wow its Caloss2 thank you for your response, i have been running old engine with my gfx card set as on the video, but i haven’t modified the nvidia settings, could also consider trying to play with new engine if the new engine video fixes the issues ive had with it in the past, the video for that is new to me so i haven’t tried it yet.


#6

So far i have been testing with new client using the changes on that video, also using borderless windowed at 1920x1080.

I have noticed missing graphics all over the game, some floors/ground fully black, some tiles missing on the rocky walls of pande for example, many npc graphics are very blurry. Having an ordinary game crash once in 2-5 hours of playtime has happened multiple times so far, since a few days of playing no pc lockups so far, every crash has happened in icc/pande just outside inf gate, just standing still and chatting.

What i remember about using the new client long ago for a few days, it mostly crashed when i was zoning, oddly that hasnt happened at all, but that is something like what Caloss2 video is about.

I will keep using it for a few more days until switching to old client again, switching it to borderless windowed mode which i didn’t use on it before.


#7

Try assigning it to Unigine: Heaven 4.0 demo in profile inspector (you will have to remove anarchyonline.exe from the previous profile you added it to first)

Then make sure you have all the dx9 files installed on your system win 8/8.1/10 do not have them natively

https://www.microsoft.com/en-gb/download/details.aspx?id=34429


#8

I will try that, today i had my first pc lockup on the new client, oddly it happened on the login screen where you type in your info, suddenly i realized that the new client has been lagging abit on the login screen occationally aswell, this was the first complete freeze.


#9

Those files on the link are no longer available.


#10

Interesting… 3 of the last freezes i have typed @ on the chat to talk to alliance relay, what the… Before the @ even appears im already frozen :open_mouth:


#11

That is very peculiar, but it suggests something outside of AO causing the problem; AO given its age and somewhat spaghetti coding (inevitable after so many iterations/repairs/patches ) is something of a barometer for system stability.

I’d suggest using ccleaner and spybot to deep clean your system.
If AO has scrappy coding, it’s a polished diamond compared to windows.


#12

Yeah, the cause can be outside AO but its certainly linked cause the effect happens only with AO, soon i will have another keyboard which hopefully doesn’t have the delay, it might be fixed that simple. Even if changing my keyboard fixes the issue, it is still very interesting how combined with AO it can cause this.


#13

Use device manager to remove any power management assigned to the keyboard ( you can not remove it via power management tools only through device manager … scrappy code remember )