Any way to get ichor for building T3 as can't place fish / shell fish traps even if fully submerged

Hi Everyone,

Is there any way to get a large amount of ichor for building T3 structures. I’ve not been able to place any fish or shellfish traps since 15 September 2020 on official PvE conflict server and official PvE server.

I’ve tried putrid flesh in fluid press but it needs a lot of putrid flesh and it is slow. 50 putrid = 1 ichor.


I haven’t had the problem placing them on the Isle of Siptah yesterday, so I’m not sure what causes the bug you reported.

If you’re in the Exiled Lands, the Abyssal Remnant is not too bad of a source of ichor. It’s nowhere near the yield you’ll get from fish traps, but it’s much better than putrid meat.

Kill the Remnant, harvest it with the best cleaver you can get, hopefully with oil of bounty and survival 30, and then cook the flesh.

1 Like

@Kolvar. Not sure if it works on pc but on the Xbox all you gotta do is have an alternate building piece on hand and when it won’t let you place something just switch to the alternate piece then switch back again and it should let you place it

I usually just kill the komodos on the border between noob river and the swungle.

Also, haven’t had any problems placing them on Siptah.

1 Like

Thanks White Rabbit, it’s the same on PC sometimes you need to alternate building pieces to get them to place, unfortunately this is not the case this time. The message I’m getting is “Must be placed in water” and alternating with a different item makes no difference.

Thanks CodeMage and Helium3. I guess it’s an exiled lands problem only.

Had kind of a similar problem several times, and the solution was placing them on foundations (slightly under water of course). Don´t know if this is the same situation, but maybe it helps.
And komodos with pickaxe, also easy prey for leveling.


Unfortunately placing on foundations is not working either :frowning:

Not sure where you are on the map but there are a few problem areas this will happen. And FYI sometimes you don’t even need to put the trap in water, it will place on the river bank also. I assume you are spinning the trap around to see the fit? Are you pushing down the middle mouse button to get an angle?

Thats really weird. :thinking:

Yeah I’ve had trouble placing traps in large wells before too. Somehow it eventually place a few. Other times I’ve seen a guy get like 30 of them in one large well so… best of luck.

If you know where the Executioners Entrance is there’s 2 caves in that area(they connect) Killing and harvesting all those little spiders in there is a good way to get Ichor, just be careful in the back of the cave where the Executioner is, his adds will surround you and pin you to a wall and there’s not much you can do after that.

Hi JJDancer,

I’ve tried with middle mouse button pushed for auto align to terrain and turning it around. I’ve tried on the edge bareley submerged and completely submerged. I’m trying to place traps in the same places I put them maybe 1 or 2 months ago; The huge lake at mounds of the dead, on the river at F6. I’ve also tried at river at the bottom right of D9(but this is the 1st time I’ve tried to place them there). Other players which already have fish traps in those locations can still harvest their traps OK. I had traps at F6 but went to move them to the mounds. When I couldn’t place them there I tried to put them back at F6 but that failed too.

Someone in chat said they were able to place traps OK at the starter river. I tried and I was able to place them there OK, both hardly submerged and fully submerged.

Thanks WhiteRabbit

I have placed fishtraps at the mounds lake before and dont recall any issues there myself. Have you tried dumping those traps and making new ones? I cant think of anything else, sorry. Hope you find a solution.

Yes I did :frowning:
No worries, Ignasis said will send it to devs to see if it’s intentional or not.


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.