Building pieces won't attach after Derketo DLC

Game mode: Online private
Type of issue: Bug
Server type: PvP
Region: North America

I’m continuing a build started before the Derketo DLC. When I attempt to add more structural pieces, 95% of locations on my build will not longer allow additional structure. Even pieces already installed will not re-install to same location after I remove them. I’ve been building in Conan for years and know many of the tricks to make difficult pieces attach, but today the attach function is broken.

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Attempt to add building piece at location with good stability and clearance.
  2. Piece will not attach where it normally would.
  3. Removing an already installed piece will then no longer accept same piece back at same location.

Hey @Tyberiuss

Do you have any mods installed in your server and/or client?

Yes, mods are below, but I run the same mods in SP and building is fine there. Base is on north side of Ironbreaker Ridge (south side of ridge has a small no-build zone close to Sepermeru). All worked fine the day before the Derketo DLC.

  • Pippi
  • Savage Steel vol 1
  • Savage Steel vol 2
  • Emberlight
  • Fashionist
  • Asshuri Treasures
  • Arena Pier
  • Roleplay
  • Shadows of Skelos
  • RP Aesthetics
  • Riverboats of the Exile Lands
  • Stabilize Camera

Did something happen to the mesh or no build zone of the area?

My server admin reports there is now a build broken zone that extends from the Unnamed City out to Klael’s Stronghold and Ironbreaker Ridge and even extends eastward to Muriela’s Hope.

1 Like

We’re poking our team about this and will update this message once we hear back.

Also, the issue seems to now be intermittent as our server admins test the broken build areas.

Its not on your list, but are you sure you aren’t using one of the admin only build anywhere mods?

I’m not an admin, and the server admins that tested used no special commands or admin mods.

Multigun, we had previously used Admin Build Anywhere but that was prior to our recent wipe. So technically “not on this server” We did just add your LBPR - No NPC Camps but for now we had to remove Shadows of Skelos.

The behavior is odd as it appears to manifest when both SVS and the Riverboat mod are loaded, though it will persist even if we unload the Riverboat mod.

I posted in Unofficial Official discord but will post this here as well, when the behavior occurs, the following gets posted to the server log:

[2019.10.11-13.22.02:407][922]building:Warning: Code: ABuildingBase::CleanupEmptyBuildings - Found an empty building after loading, destroying it: /Game/Maps/ConanSandbox/ConanSandbox.ConanSandbox:PersistentLevel.BP_BuildPillar_C_30
[2019.10.11-15.50.58:911][709]LogNavigation:Warning: DoAsyncGeometryGathering: skipping an element with no longer valid Owner

This error is written to the log when a player attempts to place a building piece, in this case a sandstone pillar. The piece is consumed from the hotbar, but nothing is placed in the game world. No error message or warning is shown in game. The piece looks placeable and is in a valid building location.

I got the same problem on my modded private server. About 95% of players cannot build.
Servername: RU_FOBOS_Calamitos mod’s_x3 no wipe (PvPvE)

Pippi - User & Server Management
WARRIOR Mutator for Conan Exiles
Admin Skelos Collector for WARRIOR
RP Aesthetics (RA)
Conan Sexiles
Glass Constructions and more…
All The Little Things
Savage Steel
Exiles extreame
Unlock plus (Wich Pickup
No Rain Only
The Age of Calamitous

Same here :frowning:

Mod list:

PD: I will post the areas soon.

Its some sort of mod issue sounds like. Just not sure what.

Yes and no, Multigun. While the behavior does not appear to happen on unmodded servers, the list of loaded mods across servers and on our test server show mutually exclusive lists with the possible exception of Pippi which should do nothing with regard to building.

I agree the behavior is mod triggered but I suspect it is something underlying in the game or devkit rather than something specific a modder did. Seeking solutions not casting blame, but I suspect it ties to the recent undermesh prevention work.

For example, on my server I removed all mods and behavior cleared (great!). I then began adding mods back one by one and testing. I began with Pippi, no issue. I got to SVS and the behavior returned (bad).

Next I reached out to Senja, author of SVS and we got on her test server, loaded game.db and ServerSettings.ini from my server with only Pippi. No issue. We loaded SVS…no issue. We loaded Riverboats mod, behavior appeared.

I then deleted every building and placeable on the test server leaving the mods in place. Began building with no issue. I then began loading every build piece and placeable from both Riverboats mod and SVS…the behavior never returned on the test server.

It is not Riverboat or SVS specific because Senja knows another server running Pippi, SVS and Riverboats with no issue. One of the posters above has issue with neither Riverboats or SVS loaded (though they have Pippi, who doesn’t?!)

I have provided an error log snippet that occurs exactly when the behavior happens. I am hoping Funcom can tell us what this means or implies.

In my testing the behavior happened when a player attempted to place a build piece in an invalid area (other landclaim or no build zone), that set the behavior in place for everyone across server in large swaths of the map until server restart.

Hey guys coming from Xbox here. Devs you added more rock inside the caves at Boundary Spillway above Swagger rock and covered half of the stuff I had inside the cave as my sweatshop. First why did you do that and 2nd can you undo it so i can get my stuff back. I have a t4 smelter stuck in the wall, a t4 cook stuck in the wall. A kiln, an improved stove, 2 armor benches with a t4 and legendary armorer, 4 dryers full of branches and 2 cupboard stuck in the wall that I can’t loot my junk out of. Can ya fix it back. Thanks

Wrong thread DecimusX, please don’t commandeer the thread for another topic. What you describe has been addressed in other threads as done by intent by FC dev to close undermeshing areas. What is reported here is a server wide loss of ability to build in valid building areas.

You may want to post here: Is this change of the map intended? Are there more changes to the map?

1 Like

So, those are some areas that have this problem:

TeleportPlayer 21847.310547 11057.225586 -857.220337
TeleportPlayer 67612.828125 58129.773438 -1308.649414
TeleportPlayer 310376.09375 151532.9375 -18754.351563

They work sometimes, and sometimes not…

@Shupa I also have the strong suspicion that such strange issues belong to areas where they fixed undermeshing. The issues definitely occur since the last Funcom Update. We also have a strange issue on our server. There are no issues about building but all the players get kicked of the server if a special Player is visiting his base built with vanilla tiles (he has another base also built with modded building tiles where the issue above doesn’t occur) and if I as an Admin porting back to my base (and we don’t have ELi on our server). The server is stable but the players get kicked off when the above condition is fulfilled.
I noticed, that they fixed undermeshing next to both areas of the bases involved. I will try to make some pictures of it.
Our server was wiped on the 11th of September.
The whole issue reminds me of the log in lag for modded servers one year ago. No modder was able to change something about and everytime we pointed out the problem to the community Devs they told us it is certainly a modproblem. At least it was a Funcom Problem and the log in Lag vanished with the release of the new Moddownloader tool.
Now there are issues in building and server kickoffs and also now the Modders can’t do anything about. They cooked their mod with the newest Devkit version, they tested them in the Devkit for SP and MP, they tested them on client and server and they tested them even with apparently problematic modlists. What should they do if they don’t find any issues but on the servers of the players there are? it must have something to do with the changings they released with the last gamebuild- maybe the undermeshing Fixes? If yes Funcom should step back to do fixing of all the undermeshing possibilities of the map if they produce kickoffs and building issues with it. The PvP community is the smallest community of CE. Using cheats is a normal behavior in PvP it seems.
The basics of this open world game should not be sacrificed for PvP. However, all the restrictions introduced so far have been implemented for this reason.

1 Like

Another area:

TeleportPlayer 47548.796875 161390.171875 -10203.456055

@TwoJay So you are seeing the same loss of build behavior? Can you post your modlist please?