Climbing is bugged, can not climb

Why I can not climb this?

I tried to discuss about it here when we were only in test-live , but everyone answered that they could climb perfectly ( a straigh line of walls … :speak_no_evil: :hear_no_evil: :see_no_evil: ) , while I was talking about “exploring the world” , so un-even surfaces …

cause there had been a lot of work poured into the previous climbing animation - especially for un-even surfaces like the Unamed city top pillar parts … and it feels like a regression with the new animation non having these adjustments ( have you tried to climb the “new lands” grey ones towers to get on top on siptah ? it’s a mess )

and yes even with spacebar continuously pressed down ! :wink:

Agreed ! Climbing has been buggy as for a while now. Uneven surfaces are a frustrating nightmare to climb. I’m another of many that has posted in the past about it but it seems something that funcom is not keen to look at. Persistence is your only chance.

Actually they are, there are some improvements made to it which are still undergoing testing. As someone playing on a beta build, I found it much easier to climb, not perfect but easier.


That’s great to hear! Thanks for the good news :relaxed::+1:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.