Conan Royal Armor and Watchers Recipes Gone

Game mode: Online official
Type of issue: Bug
Server type: PvE-Conflict
Region: 6445
Mods?: No
Edition: Steam

Bug Description: I have the Conan Royal Armor and all of the Watchers recipes unlocked. When you go to craft them none of the recipes show in the artisan/armorers bench. When you check your feats, they no longer appear.

Steps to Reproduce:

  1. Go to armorer or artisan bench and search “Watcher” or “Conan”
  2. Open feats and search “Watcher” or “Conan”

I made a few of those watcher torches a week or so ago and now they are gone.

Game mode: *[ Select one: (Online official 7059
Type of issue: *[ Select one: Bug
Server type: [ Select one: PvE-Conflict | PvE ]
Region: [ NA ]
Hardware: [ Series X ]

Bug Description: My clan and I have been playing a long time, we built a ton of 7059 on Xbox Official server. We all watched the Twitch to get the watcher stuff. I haven’t played in awhile but logged in to start playing on our server. My clan has been refreshing. I can’t make any of the Watcher stuff anymore. The book case, the armor…all the feats are gone. I can pick the stuff up and move it but can’t make anything new. Please help. I can’t live without bookcases!!! Yes. I definitely had it before

Steps to Reproduce:

Please provide a step-by-step process of how the bug can be reproduced. Please be as detailed as possible; the more details, the easier it will be for us to find and fix the bug:

  1. No watcher feats. Me: NinjaKittyJen/ Yennifer/ Galactic Empire
  2. No watcher feats for clan member WYD Step Bro!!! Same clan.
  3. (etc)
1 Like

From what I can tell given the amount of reports I’m seeing and my own experience in 2 different accounts it’s an across the board issue. Can only assume that someone screwed the pooch with the watchers feats when they where doing their maintenance.

1 Like


Same issue here

Game mode: Online official
Type of issue: Bug
Server type: PvE
Region: 6442 (Siptah Official Server)
Mods?: No
Edition: Steam

My recipe for Conan’s Atlantean Sword is gone. I haven’t tried to craft it in ages, and not at all since Siptah came out. Today for the first time in a few years I went to craft it, and I can’t find the recipe. My Watcher recipes are also all gone, too. Twitch still shows me unlocking them, and I know I made them previously.

Like the other 20 posts in the last two days, it’s broken for everyone. They are aware

i can craft the royal armour…

not the watcher though!!!

I read your post and I just tried to remove some watcher torches from a wall and could not even though they were not damaged so I had to destroy them.

However I went to see if I could craft the atlantean sword and I could so there is that. I only had a bench with no thrall to craft so I only had the lower tier sword to craft.


1 Like

I read a similar post this morning went on ps4 could find iron version of sword in improved black smith’s bench but not starmetel I had made several 2 days before probably a temporary glitch not the first time conan sword has disappeared. Didn’t mess with twitch so no input there.

In my case:

Royal armor is still there;

Watchers sets and items are all gone (and my account is still linked to twitch)

Yes I lost my Watchers feats too. I’m on PS4.

But I still have my Conan Armor though, it’s in the armorers bench.

Anyone got any update on this? I hope they find a way to disconnect the rewards from twitch drops. It’s so annoying having to reconnect my account every time there’s a mixup between twitch and funcom.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.