Conan Royal Armor Recipes missing after buying the two additional DLC's

Game mode: Online private and Single-player
Type of issue: Misc
Server type: PvE
Region: NA

I had the Conan Royal Armor Recipes in-game but when I bought the East / West DLC packs they all disappeared. I made a new single-player game to look in the admin panel and noticed I had the Conan swords there, but it fails to spawn the item if tried.
I bought the game on steam early access but somehow the DLC purchase change the flag to post-release?
I submitted a ticket through Funcom with proof of purchase with dates but just got an auto response to make a post here for “community help” Ticket # 1085625

I have tried to :
1.uninstall the DLC = still missing recipes
2.going into the admin panel to see if the armor still exists in game = no (but now the post-release swords are there)
3. Contacting Steam and Funcom support = Steam sent me to Funcom and Funcom sent me here
4. Posting here.

Any help resolving this issue would be great.

1 Like

I’m having the same issue. I’ve been waiting for a reply for awhile now about me missing mine.

Did it disappeared after the East or after the West DLC?

This is an odd one. I bought the Jewel of the West and then the Khitan one after. My Royal Armor is still in the Handcraft menu.

You guys are using I and checking the Handcraft menu right? Its never been on the Armorer’s Bench.

1 Like

I bought them together

I had all the recipes in my inventory crafting menu. I’ve never seen them in any crafting bench.

After a bit of testing I have found that the culprit was a mod. I never even thought to check since it was an official DLC. I didnt think a mod could disable it, but there you have it. I have contacted the mod author to make him aware of the issue. I am highly embarrassed to have wasted everyone’s time when the solution should have been obvious, but maybe it will help the other gentleman with the same issue. Anyway thanks for your time.

1 Like

Depends on what the mod does. They cannot actively disable the recipe. But depending on how the mod is built, they could either override the necessary data tables to make the recipes happen (direct editing instead of using a mod controller), or they could be using old assets from a much older dev kit that don’t reference newer code with those recipes in it (usually the mod itslef hasn’t been updated in a long time too).

It was a PVE building material reduction mod. One I had used a long time ago in single player - it is up to date but I can’t say what dev kit or assets the modder was working with.

Sounds like then that instead of using a mod controller to merge a data table into the vanilla one, the Mod author chose (or unknowingly, there is documentation on this stuff but you have to really hunt it down, it’s not like the dev kit has an instruction manual) to directly edit the data table instead. By doing this, they are overriding the data table that the game uses, and since the game uses a data table whose hidden value contains DLC content, it then causes the issue that you see.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.