Dedicated server can't get past port test

So I’m running the dedicated server 1.0.9 on a slave PC, and I’ve opened the ports listed in the app, in everything possible. I even went so far as to shut down my virus protection, windows firewall, and even for a quick test I shut down the router firewall too. I then tested the ports and they all failed…

So then I tested it on my main PC with the same tests… failed…

The only good news is, that after I opened those ports on my main PC, I was able to do a direct game invite and he could play on my game directly. With my network he said he was not suffering any lag, so with it being PVE we had no issues. Except not being able to travel more than spear chucking range away from each other lol.

Anyone have any ideas as to the cause?

So one of my friends enabled dmz on the server pc, and we can connect. It’s been working for a few days, but I don’t like that my server is effectively outside the firewall all together.

Also, as an update. When I launch, the 3 ports test fine. However, If I shut down the server, to fix errors and the like, when I test the ports again the Steam Query Port fails and I have to reboot the server PC again. Any thoughts?
Edit: Duh… The app is still running data through the port after the shutdown, so the port is busy. I waited a couple minutes and the port worked.

have you gone into your router/modem and checked to see if the NAT is set to “Open” and your UPnP is on. They sometimes suggest going into router/modem turning UPnP off, re booting router/modem and then turning it back on with a reboot of game system to migrate changes. I had great success with this.

1 Like

Did you do port-forwarding on your router to the slave PC’s IP you run the server on?

1 Like

I’ll check the NAT again, and try the UPnP reboot trick.
And yes, the port forwarding was set on the router. I’ve done this for other games many times, so I have had some exp with doing this. That’s why I tested with all the firewalls down after port forwarding failed. I figured if I could get it running at all there was a problem somewhere in my server.

So far the only way I can get the server to connect is to place the salve/server PC outside the firewall (DMZ settings) After that it connects. That is NOT an ideal situation.

I’m, actually getting a new modem/router at the end of the week. I may not have any trouble after that. (400Gb speeds and no data cap… have to do it lol)

Also, I’m going to post this to the bug page, and see what the devs say. Even though a google search reveals hundreds of similar cases without a single one posting a working solution… O_o

O_O so… it works now. Thank’s Xium, the UPnP trick worked like a champ. I shut down the DMZ, and turned off the UPnP. Turned it back on and BAM!!! ports tested green and I connected without issue.

It’s sad how sloppy I’ve gotten. That probably would have been one of my first checks 5 years ago, but I’ve not had to fix anyone stuff in so long I’ve lost my touch.

BTW, my NAT mode is RoutedWithNAT, and permanently set. I’ve not been able to change it so it fell in the forget about it category lol

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.