Delving bench. Weapons, yes. Armor, no

Just yesterday I tried the delving bench and was able to delve normal, dlc and legendary weapons.But when I tried armor, nothing worked. I tried the same armor that I did successfully about a week back on another server. I went back to that other successful server and now the same armor I did before doesn’t delve either. So it’s a new bug. All things I tried before and after were freshly made btw.

1 Like

What armor are you trying to delve?

The Pictish Warchief recently. Before I did the Hyperborean Slaver successfully but now it’s just like any other armor I try. Nothing works.
Weapons do just fine.

Wierd, any armour from the dlc never worked for me…
So this surprises me

1 Like

Yes Pictish is dlc but Hyperborean Slaver is not. As I have stated, the Hyperborean Slaver worked before but now it does not. Just the regular Light, Medium, and Heavy is supposed to work. That does not. That’s my point, no…armor…is… working now.

I will check later today to see if it was just a wierd day or whatever. And yes, I did try verifying files and relogging.

Ahh I understand,
I will try too this evening, have nt done it since update.

Oh, btw. What I mean by weapons working is that they do. I did dlc with that even. I did the Pictish Bow twice and got the Frenzied Bow and the Masterful Bow. Then I did a Hardened Steel Bow and got another recipe for the Frenzied Bow. So that was 3 tries and 3 successes. So go figure. Lol.

1 Like

Hey question on delving if you don’t mind. Can you repair the delved weapon and then do a 20 Eldarium delve on the same weapon again?


Edit. Be smart. Get a Nemedian helmet. Farm used weapons from npc. (Hardened steel, Serpentman) equip both on thrall and gas arrow.

Free repairs.


I don’t think DLC armors are supposed to delve in the first place but I’ve just tested Hyperborean Slaver Helmet, Hyena-Fur Gloves and Relic Hunter Trousers and they all delved without issues.

DLC Katana Yamatai version delved for me successfully. Got the Wicked Edge. Wanted the Envomed Blade. :slight_smile:

Then perhaps it’s server specific then. My server has been having some other wierd issues lately.

A player on the Official Server I play on also had an issue delving things he knows delv’d, He said he picked up and replaced the bench and it fixed that issue. Just an idea.

1 Like

Thanks. I will try that.

Hmm I checked every kind of weapon and armour, all gave me recipes.
Except for shields.

1 Like

We had no luck with shields either

1 Like

Because there are no delved shields :woman_shrugging:

1 Like

Pretty lame there no shield recipes… maybe a dev or pr person can gives us some info if we are going to get shield recipes?

It would also be great if we can’t delve shields that the bench stops eating the eldarium.