Fatal erroring like crazy with new PC build - may be new 4070 card to blame?

Hi there,
So I just built a new PC…which let me preface with I built my last PC that I played Conan Exiles for years on. It was getting outdated and I needed a new vid card so it was time for an upgrade. So I can’t for the life of me figure out why my old I7 7700k and RTX 2060 would perform better than my new system.

New System is an Asus Strix B650-A with an AMD Ryzen 7 7700x processor and the brand new Asus Dual 4070 graphics card.

Error logs ellude to this being a graphics card driver issue and a run time issue. I have tried thus far:
validating CE files, reinstalling CE, reinstalling mods, reinstalling graphics cards drivers. Prior to the reinstall of CE and the graphics card drivers it was hard crashing and blue screening. Now it’s just randomly fatal erroring.

The ONLY way I’m able to reliably cause it to fatal error…is by tinkering with the graphics settings. Hitting “restore defaults” on graphics settings caused an instant fatal error.

I love this game! I help with a mod community…and upgraded to learn how to mod myself. This is one of my favorite games…yet it’s virtually unplayable on my new system…when it should be out performing my old PC.

My guess is that this card is such a new model card that maybe CE is struggling with supporting it??

On my list of things I’m going to try to test my theory out:
Running CE in single player with no mods to make sure it’s not a corrupt mod file (even though the multiple reinstalls of mod files should have made this a non issue)
Using an older video driver
Swapping my new card for my old card and seeing how it plays on that.

But I’m REALLY not keen on the idea of having to run older drivers to get CE to work…if that ends up being the issue/solution.

Edited to add on list of things I tried in the OP:
Disabled onboard graphics
reinstalling the game
verifying files
reinstalling mods
testing single player no mods (fine)
testing single player with the same mod lists from servers i’ve crashed on - fine
tested display settings in single player - windowed, full screen, etc - can not crash it in single player
testing display settings on a server - results in crashes usually soon after.

This is the most common error in the logs that I get:
[2023.05.13-14.55.17:929][897]LogThreadingWindows:Error: Runnable thread TaskGraphThreadHP 11 crashed.
[2023.05.13-14.55.17:929][897]LogWindows:Error: === Critical error: ===
[2023.05.13-14.55.17:929][897]LogWindows:Error: Fatal error!
[2023.05.13-14.55.17:929][897]LogWindows:Error: Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xffffffff
[2023.05.13-14.55.17:929][897]LogWindows:Error: !0x0000000000000000
[2023.05.13-14.55.17:929][897]LogWindows:Error: Crash in runnable thread TaskGraphThreadHP 11
[2023.05.13-14.55.17:955][897]LogExit: Executing StaticShutdownAfterError
[2023.05.13-14.55.17:955][897]LogWindows: FPlatformMisc::RequestExit(1)
[2023.05.13-14.55.17:955][897]Log file closed, 05/13/23 07:55:17

which just for the record I have started sending error logs with notes (under the steam account MystressX)

Is it giving either RenderThread or D3D errors when it fatal errors?

If I had to guess, it’s the onboard graphics for the processor (this AMD chip has 2 graphics cores) conflicting with the nVidia graphics card. I would try disabling the onboard video so that it is just running off the 4070. UE4 has issues with this kind of thing.

let me see what the latest error log was…thus far it’s been…

[File:C:\B\tech_exiles\code\Engine\Source\Runtime\RenderCore\Private\RenderingThread.cpp] [Line: 805]
[2023.05.12-11.16.07:039][326]LogWindows:Error: Rendering thread exception:
[2023.05.12-11.16.07:039][326]LogWindows:Error: Fatal error!

[2023.05.12-17.23.21:983][123]LogThreadingWindows:Error: Runnable thread TaskGraphThreadHP 9 crashed.
[2023.05.12-17.23.21:983][123]LogWindows:Error: === Critical error: ===
[2023.05.12-17.23.21:983][123]LogWindows:Error: Fatal error!
[2023.05.12-17.23.21:983][123]LogWindows:Error: Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xffffffff
[2023.05.12-17.23.21:983][123]LogWindows:Error: !0x0000000000000000
[2023.05.12-17.23.21:983][123]LogWindows:Error: Crash in runnable thread TaskGraphThreadHP 9
[2023.05.12-17.23.22:013][123]LogExit: Executing StaticShutdownAfterError

This was the last one it spit at me just now…[2023.05.13-11.26.20:117][417]LogMemory: Platform Memory Stats for WindowsNoEditor
[2023.05.13-11.26.20:117][417]LogMemory: Process Physical Memory: 6320.85 MB used, 7169.19 MB peak
[2023.05.13-11.26.20:117][417]LogMemory: Process Virtual Memory: 12238.60 MB used, 15761.60 MB peak
[2023.05.13-11.26.20:117][417]LogMemory: Physical Memory: 15407.96 MB used, 16486.68 MB free, 31894.64 MB total
[2023.05.13-11.26.20:117][417]LogMemory: Virtual Memory: 20786.93 MB used, 16486.68 MB free, 134217728.00 MB total
[2023.05.13-11.26.22:679][417]LogWindows: Windows GetLastError: The operation completed successfully. (0)
[2023.05.13-11.26.22:679][417]LogWindows:Error: === Critical error: ===
[2023.05.13-11.26.22:679][417]LogWindows:Error: Fatal error: [File:C:\B\tech_exiles\code\Engine\Source\Runtime\RenderCore\Private\RenderingThread.cpp] [Line: 805]
[2023.05.13-11.26.22:679][417]LogWindows:Error: Rendering thread exception:
[2023.05.13-11.26.22:679][417]LogWindows:Error: Fatal error!
[2023.05.13-11.26.22:679][417]LogWindows:Error: Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xffffffff
[2023.05.13-11.26.22:679][417]LogWindows:Error: !0x0000000000000000
[2023.05.13-11.26.22:698][417]LogExit: Executing StaticShutdownAfterError
[2023.05.13-11.26.22:784][417]LogWindows: FPlatformMisc::RequestExit(1)
[2023.05.13-11.26.22:784][417]Log file closed, 05/13/23 04:26:22

Which I just tested in single player…with no mods…I could NOT get it to crash! Minute I logged into my friend’s server…it crashed. So I’m going to try reinstalling mods…yet again. And then I’m going to test on my 2 private servers as well as hers. But I’m the ONLY person crashing like this on her server right now (mind you it’s low pop)

Which I’ve found previous reports on similar errors…and there didn’t seem to be a solid resolution.

Things I’ve also tried based on similar error logs…

Given it’s a new build with on board graphics as well as a graphics card…I have disabled the onboard graphics. Like I previously stated I’ve already tried reinstalling graphics drivers, reinstalling the game, verifying the game, and uninstalling and reinstalling mods

It is indeed the render thread issue and as you say, doesn’t always have the same solution because its a UE4 thing, rather than a CE thing…Usually, it is something with the driver or some video setting. If single player, no mods isn’t crashing… I wonder if one of the mods is using some kind of unfriendly graphics setting. Are you running the game fullscreen or are you windowed? Windowed can cause issues.

Also, are you installing the game ready driver from GeForce Experience, or are you downloading the driver from anywhere else? The game ready driver is always the newest.

already tried this…it’s disabled already :wink: . Did not solve.

running fullscreen. Tried windowed and full screen in single player…did not crash it.

Single player…I can not crash it.

Multi player? Crashes on multiple servers with no rhyme or reason…I could just be standing there. Crashes in different areas.

Tested the mod list in single player that crashed in multi player…could not get it to crash. So I don’t know what would be different between multi player and single player that would cause it to crash like this.

The fact that it’s crashing like mad on a Ryzen 7 7700X with an RTX 4070 but ran just fine on my old i7-7700k with an RTX 2060…is kind of just insane to me.

from GeForce Experience/nvidia directly. It IS the latest up to date driver…and I have already tried reinstalling it

So you are using SLI? SLI will also cause this. If you are using SLI, see if you can run on just one card by disabling it.

holy hell I figured out the problem/fixed it. Alright…so I switched from Intel to AMD…first AMD build. And AMD has this thing called DOCP. Enabled DOCP in bios…problem solved. That friggin simple. Smacks forehead and dies inside


lol no it’s not dual graphics cards as in 2…i know it’s stupid confusing. The card itself is called the “Asus Dual”. Putting words like this in here so in case people go deep diving in the forums like I did they may find my solutions. Intel put out a newer cheaper 4070 chipset…this particular chipset just launched in April. Hence why my knee jerk reaction particularly with games crashing and not the entire system was that it was likely the new chipset not playing nice. Thankfully much easier fix of just a bios setting not playing nice with my memory. Most people would expect default bios settings to still play conan…but apparently nope. At least not with this board/build. Which I did NOT see checking XMP/DOCP setting for possible solutions for these bugs

1 Like

That is probably a feature relatively new compared to the bug since its a ue4 related bug. I googled DOCP and saw it helps with rendering and thought “well thats probably it!”. Definitely keeping a mental note for future issues people may have. Thanks for coming back with what fixed it.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.