Follower says returning home, can't rescue says can't find follower

*online official [Enter game mode here: (Online official | Online private | Single-player)]
*bug [Enter one of the following: Crash | Bug | Performance | Misc]
PVP: [Enter one of the following: PvP | PvE-Conflict | PvE]
Mitra? [Please enter your server region]
Server 6150


[Describe the bug here]


Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. No clue currently I can’t even play the game my stamina bar is also hosed
  2. I can run and the stamina does not go down or climb. but if I jump it goes down and will not come back up
  3. It started when my player got stuck in the malestrom inbetween my rhino pet and rhino rider I could not escape.
  4. I logged off for awhile and when I came back my rhino pet was back at the base and my rider says returning home but when I click on rescue it says can’t find pet? and when I ran home the pet would appear below me and my character spread like jesus standing on top of the rhino and I could not move. So I logged off again and eventually made it back to my base and I can’t climb any ladders either for some reason. HELP
1 Like

All thralls and pets can be tracked via the Follower tab when you press your Inventory and then across to the FOLLOWERS tab. To the far right of the screen you will see a greyed out eye-like icon next to the name/title of every thrall and pet (follower) you have. Click on that icon and go to Map. You will see that highlighted Follower on your Map as a person-shaped icon. You can then go to that point to fetch the Follower

image

1 Like

Have you tried removing the bracelet to respawn at your bed or bedroll?

1 Like

why, would that resolve/prevent the thrall deletion?

I believe from what you said and how you said it that your character is glitched and the game thinks you are mounted.
if you “reset” the character by removing the bracelet the mount should default to where you told it to guard last, and the stamina problem should be fixed.

It’s just a shot in the dark, but if you can get back to your body easily it couldn’t hurt to try.

3 Likes

Thanks everyone, I didn’t think of removing the bracelet, but after a couple of days it seems to of reset! and my pet is back at the base and I can now run and climb ladders and my stamina resets. I I think whoever said that the game thinks I am still mounted was correct, every time I logged back in and got closer to my base suddenly the game would lock up and I would be on top of my mount.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.