Horrible FPS as I start the game


#1

UPDATE: Got it running!
I had tried the Full Client trick (I’m not on Steam), and it helped a wee bit, but it was when I opened a door just after I jumped into the first whole in the cemetery that suddenly everything kicked in (which went along with what someone said about the tutorial being fps horrible). I even upped the video to Medium.

So, we’re all good. Thanks all for all your help.

Greetings,

Well, I downloaded, installed and gave it a whirl. Man, the fps is so bad that it’s pretty much unplayable. I tried lowering settings but to no avail (the default set me on the lowest for just about everything anyways).

I then thought it might be my Nvidia card—known to have issues with games and requiring tweaks to fix them. I found one thread here on this site (https://lomsglobal.com/threads/nvidia-how-to-make-swl-run-more-smoothly.2130/), and I went through the steps, but, again, to pretty much no avail.

Now, i did notice that the little set of double arrows in the upper-right hand corner are rotating; hovering over them states it’s downloading game content. Well, I hope that may be what’s causing all the fps issues. Does the rotating arrows in fact mean that it’s downloading? I’ve set the downloading throttle to full so that it will do it as soon as possible.

Additionally, someone on the Reddit thread told me that the cemetery tutorial is horrible for fps problems, no matter what system you have.

Finally, my system stats, though not top of the line, are surely able to handle this game—I play other games that are far more GPU intense and do so with no problems.

Win 10 64-bit
i3 third gen 3.3 GHz, all four cores operating
16 gigs ram
Nvidia GTX 650, updated driver
lots of hard drive space

Any suggestions would be greatly appreciated.


#2

What Resolution do you play on? As that probably is the biggest factor when it comes to performance in the graphic options.


#3

Well, it set itself to 1920x1080, but even the menus are horribly jagged (fps) and everything else that shouldn’tt be related to the resolution.


#4

Change from directx 11 to directx 9
Then restart client


#5

Sorry, should have mentioned that I tried that already. Thanks.


#6

A little more technical bit has helped many


#7

O.K.
As someone who just installed the Game on a new system, I’m pretty sure I know what the problem is.
First, get out of the Game.
Second, open the Launcher.
Once the Launcher is open, look at the bottom, in the ‘grey-ish’ area. There should be three buttons: Account, Notes, and Options.
Press ‘Options’.
On the far right of the screen, beneath the section that says ‘Audio’, will be a section labeled ‘Bundles’.
The first option under ‘Bundles’ will be ‘Full Client’.
This will NOT be checked off.
You need to check it off.
Save your changes and exit the Launcher.
Open the Launcher again.
You will now download the Full Game Client.
You see, for some strange reason a while back the folks at Funcom decided to set the Game up to only download the Minimum amount of the Client required to actually get into the Gameworld. Unfortunately, even on a high end machine, this renders the Game almost totally unplayable. You were having so very much difficulty playing because nothing you actually needed to PLAY was loaded on to your machine yet. Get the full client and things will be fine. I cannot imagine how many new players this has cost them since they started doing it.


#8

That advice won’t work for the steam client as it ignores that setting and gives everyone the minimal install.


#9

Even if you change it AFTER the initial install? Even if you try the ‘Repair Broken Data’ option? Is there simply no way to get the whole Client? Because if not, I can’t see how the Game would EVER be playable.
I’ve never linked the game through Steam, so I’ve no idea what they have done to it (shudders).


#10

You just have to stand still for a minute every time you enter a new area while it downloads stuff and then it runs at its usual choppy level instead of unplayable-choppy. Even with the full client this is by far the least smooth 2012-era MMO I’ve played.


#11

I’ve never had any real trouble with chop in this game when run with the full client. Of course, I do have a bit of a RAM fetish (24 gigs on the Desktop and a paltry 16 gigs on the Laptop), which might go a long way to explaining that. But with a minimum client? None of that matters.


#12

Shouldn’t matter with any client, the game runs 32 bit and can’t really exceed 2GB of ram usage. It’s the CPU limits that make it stutter.


#13

See my OP, please, for the fix.

Thanks.


#14

mine consumes 2.6-2.8GB before it ultimately crashes on it’s own “out of memory” memory leak problem. And OS memory matters to it a lot. It’s not easy to allocate sufficiently large blocks on PC with 8GB that runs let’s say browser on background (another nice memory fragmenting thing).

Anyway, OP you haven’t stated what FPS you are getting in what location and what you expect. But that PC of your will never run SWL nicely.

I3-3 with 3GHz sounds like NB/slim-desktop version. Not full desktop CPU. And SWL requires tons of CPU if things are happening, like standing in Agartha because of really poopy UI.

GT640 is another very weak spot I’m afraid (even hoping it’s not notebook version). Being the very weak version of very very old GP, even older then TSW. But GPU wise SWL isn’t that badly optimized. But it uses a lot of effects these cards have insufficient raw power to handle :frowning:

There is key to disable the UI, not sure what default it is. You may try that. When it’s a CPU problem the FPS will go up when UI is not shown (it’s still CPU consuming as it’s still processing all things, but doesn’t need to sync with drawing thread which I suspect is the cause of CPU-related FPS drop).

If it’s GPU drop, then it will react to resolution.

There may be many other reasons really, cannot tell without experimenting or seeing how it reacts and type of “choppiness” you see. Might be wrong power profile. Full memory issue. Not enough GPU memory. Slow HDD (SWL loads resources on demand and has no space to cache them, so… :/)


#15

Elenoe,

I’m going to have to disagree with you that my PC won’t run SWL nicely.

First, the i3-3 3220 is a 3.3 Gh chip for full size desktops.

Second, SWL doesn’t require any more CPU than a lot of other games I’ve played, in which both the CPU and GPU demands were equal if not more than SWL.

Third, the Nvidia card I have is a GTX 650, not a 640 (my mistype in the OP; I’ll try to edit that to correct it).

And finally, as it stands, the game now runs wonderfully. Sure, it may get a bit bogged down here and there, but that’s normal.

Thanks.


#16

so 3.0GHz means 3.3GHz, 640 means 650, and from “bad” it has turned into “wonderful”. Now THAT is Funcom level of obfuscation, you will feel like home here :smile:

Anyway, welcome aboard and enjoy the SW story


#17

Hey I have a dHp…HdP…PhD (no,that’s not it)…some order of those three letters in bad logic, mispelling and bad information all the way around! I studied hard for that!

Yeah, I was just gong off the top of my head when I put the stats down. But, thanks heavens, the game does run fine now (he said with great hope in his voice that it will continue that way).

Obfuscating with everything I have…

Thanks again.


#18

PI have i7-4790, 3,60GHz with 4 cores, 16GB RAM and GTX 1080 on my other PC. With these, based on how old SWL/TSW is, I should be getting 80+ FPS. Meanwhile I get 50-70 FPS on medium settings x) Okay, I do admit that I have usually a lot of other stuff running on the background. But if we take another game as an example here, let’s say Conan Exiles since it’s really amazing looking game with lots of details, I get +100 FPS constantly on high settings.

Even tho SWL is old game, it’s not quite optimized unfortunately :confused:


#19

Well, I have the system I built several years ago (the one in question for the OP here), which I use for games, composing music and post-processing for photography, and I definitely need to upgrade it. It can handle stuff like FF14/15 without getting real bogged down, but I have to set a lot of settings to lower status.

The Mobo for it can only take up to third-gen CPUs, so I bought an i7 third-gen to replace my i3 (just a hold-over), and it got stolen in the mail; the sender didn’t seal up the package well enough. I got my money back, but I was, like, “Well, crap! Guess I’ll just go the full-upgrade route and avoid hold-overs.” I have a laptop for all other uses.

Your system sounds quite nice, about what I’m looking for. I really don’t need a strong high-end machine, just enough to play games at decent stat levels and to process what little photography I do. But the GTX 1080 definitely is on my radar!


#20

I have the full install. I’ve tried all the tricks that we created during the TSW years. Long story short: This game performs terribly on my PC (worse than TSW, but TSW was also performing poor) while games like Destiny 2 does not.

1-3 FPS slide shows are not uncommon.