Huge Lag after entering "Houses" in larger maps

Hello, first time here be kind pls. not sure if even right section and search is still unhelpful for me.

Unplayable lag after entering and killing first set of mobs in “houses” set in maps that require game to load resources when entering said instances. Thus far I’ve only managed to enter the Mausoleum in WS(1st and 2nd character had no issues, but were cleared the Mausoleum before the event ended.) Also the Great Hall of Heimdall gives me this issue.

First issues with lag started after the Halloween/WB event ended.
During event had minor issues with combat starting while the cinematics especially in the werewolf event were running.

My issue starts after killing the first mob or group mobs. After that my ping rises to 4500ms+ in just a few seconds, even leaving the instance is almost impossible even if I’m not in combat. My friend in same instance have none of these issues, we live in same city and have our connections bought from same ISP.

Win 7, 64 bit, Phenom II x6 1055T 2.8 GHz
DirectX 9 used for game
8 MB Ram
Not installed on SSD
All other programs except AoC and Discord killed & disabled from delayed starting.
ISP connection capable of up to 100MB wireless, wired connection can manage only 2 MB. Router is a hybrid that, at least when updating games will use both. Background loading set to ~700Kb max.

No other games suffer form lag or even moderate lag spikes, only AoC is affected.

Any know fixes for this issue?

Kind Regards,
Gleb Reawer

P.S. Both @Piankhi and @Lurvi gave realistic explanations to my issues, but the forum only accepts one person as the hero :frowning: Give thanks to posts #15 & #18 :vulcan_salute:

So you are saying the high ping only happens in indoor instances, and it will only start after you have killed a few mobs?

It never happens in outdoor instances, and it doesn’t happen if you just sit/walk around and don’t start combat in indoor instances?

Beyond that, it is unclear exactly what your network situation is. You say you have a wireless connection which I assume you meant 100 Mbps, not 100MB. And you also have a separate wired connection that I assume is 2 Mbps.

From what you have said, I assume those wireless/wired connections are from the ISP to your router. You then go from the router to your PC using which method, wired or wireless?

Yes, the issue only appears after killing the first mobs.

In the Mausoleum a single kill made my ping jump to ~4800ms and I lost my unconcuered run with my PoM

Almost similar in the Great Hall, no issues in the first room, but if I move towards the door on the left(only door?) my ping quite quickly rises to 4500ms+

Never outdoors, tho sometimes if I time out, the client crashes, not sure if it goes to character screen or not.

You are right about the speeds and separate connections, my router is a hybrid with both wired and wireless connection and the capability to use both at the same time. I could limit it to just one, but it helps a lot with updating games and also sometimes when browsing the net or watching Youtube.

Wired connection from hybrid router to PC

P.S. I haven’t done any dungeons due to fears that the issue would happen there too.

You can try some low level dungeon, like Sanctum, which you can solo at 80, just to check if it gives the same problem or not.

Yeah, I’ll try a solo dungeon in a day or two(RL stuff to take care of), but my highest character is only lvl 53 thus far.

Edit: Any IP I can use to run PingPlotter against to determine what causes the lag?

Edit2: Just quickly ran trough the first set of quests in The Pyramid of the Ancients. No issues. I’ll complete it at a better time. Tho I suspect nothing will happen as the lag/s appear very quickly if I’m in the “wrong” instance.

I have had the exact same issue at certain spots ingame, though unrelated to killing a mob or not.

Example is the gateway to khitai tortage smuggler guy/main town

To finish quests in this area I have ro relog multiple times to be able to move to an npc, and to finish dialouges and move away, as in a matter of seconds my MS spikes to 5k and I can’t do anything.

Same with the 1st town in KK, most of the village is fine, but certain spots give me 5k ms, though I can run past these areas before I get the full 5k ms “halt”.

Another place is atzels fortress. Ping is fine by the entrance and I can stay there for a long time without any issue, but as I approach the 1st room and the stairs it will go to 5k in a matter of seconds.

I have noticed it in other spots in the game, but can’t remember right now. I thought it was related to density of mobs, but in the entire onyx chambers it’s fine, so it’s weird.

Try to re-install the game. I have, but haven’t checked these mentioned spots after. I’ll try check out these spots again and give you an update.

About the only thing I can say is that in the past, when I was on a home network that load balanced between two different ISP connections, I used to have all sorts of terrible issues getting logged in to the game, or staying in game. Pretty much any time the load balancer would swap what connection I was on, I would get disconnected.

I’m not sure if that could be at all related to your issue, but it is worth a shot to test running on one connection I guess. One thing I believe is possible in at least some routers would be to set all traffic going to the Funcom servers to only use one specific connection. So that might be and end-goal if you find the load balancer is the issue.

The behavior you experience in-game is just highly odd and specific. I have no idea why it would only happen in indoor instances like that.

Good luck.


I think this is correct. I don’t think being behind a load balancer is a good idea for online games.


I would be very thankful if you checked the old lag-spots. Please and Thanks :slight_smile:

I know re-installing the game isn’t the end of the world, but it’s always a “Meeehh…” experience :stuck_out_tongue:

I’m going to test the Mausoleum with my unlucky ToS(I want to do all of the beginner area missions) who lost her unconcuered run there when the issue first appeared.

I have experienced huge game killing lag-spikes a couple of times, years ago. When I was playing WoT, the players were able to pinpoint a faulty node outside the servers physical location as the culprit with PingPlotter.

The deadly ping acts similar to what happened in wot. Very quick rise of ping, stuck until death, sometimes even longer and a couple of ppl got stuck in limbo. Server was insisting they are still in battle, even tho the max time was 20min and the game had been played the day before.

Edit: I was intending to quote part of your reply, but new forums, sorry.

1 Like

I would like to wait for Lurvi to check to old lag-pits first, as my crappy cable connection itself can cause minor lag spikes and will increase the steady ping with about 20-30%. Really old house with wires that are wrapped in tar-paper as insulation :astonished:

I’m hoping the issue is with the installation, but I’m ready to sacrifice the dual connection to be able to play. The remaining question would be 2Mbps wire or 100Mbps wireless to connect to the ISP & the world.
2Mbps max. due to the old copper, doesn’t matter how quick the sold connection is, it always caps at 2Mbps and doesn’t like damp weather either. :triumph:

The router I’m using is a Huawei Bonding Access Gateway H35-22. Picture of it’s connections below. Only the single DSL & LAN1-port are used in addition to the wireless connection to the outside world. I’m the only one using it and have only one PC connected to it.

https: //elisa .fi/img/content/asiakaspalvelu/HA35_takapaneeli.png

P.S. Can’t @ other ppl? FFS
P.P.S. No links? Gimme a break.

Your wired connection sounds utterly terrible, and prone to lots of potential issues. But the Wireless could also yield problems. Best thing you could potentially do is to test each connection method individually, and see how the network behaves.

This is a handy tool that plots pings and you can see things like packet loss. It will help show you the reliability of each ISP connection. It also shows your connection to each node in the network on the way to your destination, so you can see if network issues are happening at a specific location.

You could test to something simple like, or even direct to Funcom’s Servers.

The Windows 10 resource manager program should be able to show you exactly what IP addresses, and even ports used by AoC when it is running I believe.

Unfortunately I’m using Win 7 64bit and I don’t know how to find the target IP

I’m pretty sure PingPlotter does the same thing PingTracer does.

But! I used my PoM this morning and again had to go to Whitesands Isle. While there I thought “what the heck, nothing to lose” and entered the Mausoleum. This time I had no ping issues at all. WTF?

Feeling hopeful I quickly got in contact with my friend and we went to check the Great Hall. Just a minor issue, I used my DT and not my Necro who had the lag-death.
Only once did the lag indicator turn very briefly yellow, as we used the horn to open the gates and a boss attacked us immediately.

I have done absolutely nothing, no updates, no file checking, no nothing and the issue seems to be gone. I don’t think I have the stamina to test my Necro tonight. But I’m quite sure we can close this thread.

Whatever gods of games and internet there may be, they decided to have mercy on me, at least for the time being.

Thanks to everyone for suggestions and I’m really happy to see that there is such a active and helpful forum community in AoC.

Thank you all,
Gleb Reawer

1 Like

Whoops, should have re-read your posts to remind myself of those details. Not sure if Windows 7 has anything built in that does the same job.

Also, yeah, PingPlotter probably does the same kind of stuff. I’ve just never used it before.

I can’t test for myself what the IP addresses are at the moment, but I found this old reddit thread where people listed some.

Good to hear that your issue has vanished for now. Could be indicative to an issue somewhere between you and the servers.

Out of curiosity, how often did you get this latency connection issue? And how repeatable was it?

1 Like

Thank you for the IP addresses, I hope I won’t need them, but it’s good to have them for the future.

It happened 3 times in a row in the Mausoleum when it first started, all within 20 min.
The next day I again tried 3 times in the Great Hall, this time I took about 1h to re-enter the area, kill mobs and enter the Great Hall, only to die from invisible attackers. My minions did kill one enemy in one of the tries, but I only know this bc my friend said it happened. Same dude who was helping me today.

1 Like

Given that the issues were only over a 2 day period, it very well could have been a temporary problem outside your control.

1 Like

To me this sounds like you’re lagging out because you’re downloading resources to display the dungeons which should only happen the first time you visit them. You claim to have 100"MB" wireless but as far as I know there’s no technology that allows a speed of 100mb/s download so you must mean 100mbit which gives roughly 12mb/s and that must mean your 2"MB" wired allows you to download at a speed of 240kb/s. You put the background downloader to 700kb/s which exceeds your maximum speed and this is probably why lags occur, it’s normal to have high latency problems if you are utilizing 100% of your download.

I’m assuming you are using the wired connection for playing because it’s more stable then it’s probably because downloading data in the background being the problem. If this was not your first time entering the dungeon then it could be anything from your connection to your harddrive. I had huge issues back in the day when I ran a phenom II x4 and a normal harddrive, I would get random red lagspikes for no reason and the game would freeze.


Yes, this blooper of mine was explained to me earlier, but I didn’t think of that 700kb/s being high enough to fully block my connection. With my new router I’ve been able to download games ~3 times quicker than with the old using only the wired connection. I’ll need to tweak that setting again.

I don’t usually have any other programs than Discord and Firefox, for guides & googling game stuff, active when I’m playing.
My PC is quite old and built by a good friend and bad connection has taught me to be sparse and to kill any auto updaters windows and other programs have.

Yes, the wired was left alive due to it usually having less lag and jitter. Useful when playing Team PvP games like WoT and WoWS (I’m too old for twitch shooters :stuck_out_tongue:)

The HDD might be an issue, I have 2. A ~230GB SSD with my OS and some other stuff and a gifted(formatted just in case) ~465GB HDD. AoC is due to space issues located on the HDD(50%+ free space atm).

pretty sure my issue was related to some files being corrupt or something, despite doing the game files verify thing it never helped. the fresh install of the game has fixed it completely.


I have the same feeling and like you 10+ checks have come out clean. I have already created some free space on my SSD and I will re-install AoC there in a day or two. Too lazy and tired to do it right away.

I did do BC dungeon with my Necro and no issues \o/
Didn’t know how the loot thing worked and got shafted with the item, but better than my first run where someone had found a way to take several items and I didn’t get anything :face_with_symbols_over_mouth:

The crash on exit issue I was having seems to be gone after I switched to “windowed full sceen”-mode

1 Like

I selected 2 answers as solutions as both are IMHO equally possible.

Thanks to everyone for help and suggestions :smiley::vulcan_salute: