I get kicked to the main menu while loading a server and even after I connect

The game kicks me out to the main menu nearly every time I try to log in. It can sometimes take up to 30 minutes before I can finally connect to a server! It even kicks me out while I’m loading into the server. If I do load into the server there is about a 70% chance it will kick me out to the main menu. If that happens I get a “connection to server lost” message.

Bug Reproduction:

All I do is select play online, then I go to my favorite servers and select my server. Then it crashes while loading or it crashes after I connect. I’m not exaggerating when I say it can take up to 40 attempts just to connect and stay in the server.

Greetings Exile, and welcome to our forum!

Thank you for your report. Can you share with us if your console is on a cabled or wired connection?

When you finish your play session do you leave the game by the menus or leave the console on standby?

Does this happen when connecting to other servers or only a specific one?

We await your reply.

Currently I am on a wireless connection with no options of getting wired. When I end my session I quit to the main menu then power off the Xbox. This issue happens on all servers in the game except I can connect to most private servers in a few tries. Official servers are the real problem as it can take 40+ attempts to log in. When I was visiting home I was able to have a wired connection and I never disconnected once in the three weeks I was there. Now that I am back at school the problem continues.

Edit
The wireless connection is a steady 80-90 mbps download and 90-100 mbps upload with 35ms latency so the connection isn’t slow.

I too am having this problem, I came here to report but since one is made I will add to it. I run same wifi set up and close out same way. Today I can’t load into any pve server private. I’m in Australia, trying to load into Oceana servers. I’ve reset my wifi and Xbox and cleared my cache. Nothing seems to work and quite frustrated that I can’t get into a game.

Greetings,

Thank you for the additional information. In this case, we suggest you follow some steps suggested by the platform holder:

Check out what is your current NAT type: Xbox Support

Run a multiplayer connection test: Xbox Support

If you’re able to access your router’s settings, make sure that UPnP is enabled.

If possible, confirm that all required ports are being forwarded: Xbox Support

My NAT is open. My multiplayer connection says it’s all good. I am on the school’s on campus wifi so I don’t have access to the settings.

Having the same problem. Running Xbox Series X, working fine last night, now it says failed to join game and disconnects me. I get the same error on every server I try to join, including single player. I’ve restarted my xbox, my modem, and even went so far as to uninstall the game and reinstall it. The join progress bar goes about half way up, and then it disconnects me every time.

Also, my NAT is open, I’m running a wired connection, and all my other games are working fine.

Greetings Exiles,

In that case, please follow the stated on the Official servers guidelines to submit a ticket. Make sure to select “Ban appeal” as the issue type so our team can scan your accounts for other issues:

https://funcom.zendesk.com/hc/en-us/requests/new

You can read the full version of the Guidelines here: