Infinite Loading Loop

This is because the mods don’t match the server.

I know, I know… they say “OK”
It’s wrong.

If you look in your logs you will no doubt see the errors about mods.

Here’s the annoying, but simple and easy fix.
(first make sure you close game)

  1. Look at your Conan page on Steam.
  2. Click Workshop
  3. On the right side click “your files” and from the drop down select “Subscribed Items”
  4. Click Unsubscribe from ALL
  5. Go to Steam/SteamApps/Workshop/content/440900 That folder should be empty, if its not empty it and double check to make sure you are unsubscribed to all those files.
  6. Relaunch your game and try to connect to server

My friends and I have had this happen multiple times since 3.0 and its fixed it every time.

is that 100% what is actually causing this? because every time I think theres one or more mods not up to date those same mods work fine in singleplayer or on another server. I still got the loop after these steps and im going in circles trying to solve this because everyone seems to have a different solution

1 Like

Yes

That’s because single-player does not care whether your mods are updated or not… it will simply load up whatever you have
A mod mismatch can only occur between a client and a server so this only applies to online play
You being able to join other servers that use the same mods is literally proof that the server is not updated properly like I said earlier…

Not really, everyone is saying the same thing pretty much, @mofaka said the same thing above too, one step is slightly different, but it will accomplish the exact same thing. So either versions would work :slight_smile:

Bottom line… in your case… that specific server does not have all the mods properly updated

yes its not my server but my advice to them is to scrap ALL the mods and try to launch the server in vanilla because clearly some of the mods cannot update atm

Mine actually didn’t for some reason. I’m not having any issues now (knock on wood), but I did notice yesterday that after deleting the modlist file, after the 3.0.2 update, it wasn’t recreated. I reinstalled the game and had to re-add the mods manually. Really weird, and I haven’t looked today, but as far as i know the modlist file is still gone.

Maybe I should check that again tomorrow :thinking:

2 Likes

Yea, I think it gets recreated only when you either add mods to the “selected” list either in the launcher or inside the game, or when your game restarts to auto-connect to a server with mods.

1 Like

Well, I checked again this morning and there isn’t a modlist.txt file anywhere in my ConanSandbox folder and I don’t see a ModRestartData file in the saved folder either.

Maybe I need to verify files? I’ll give that a shot. Can’t hurt, right?

1 Like

Well the ModRestartData file along with the servermodlist.txt only get created when you get the loop :slight_smile:

Since those files specifically contain the reconnection data to the server and the list of mods used by the server. These two files only get created when your game automatically goes down for a restart to try and load the server’s mods right after a mismatch error.

They are not created or used during normal operation if everything is working and you’re not getting a mismatch error.

So it those are missing that’s fine, like you said you were able to play.
If your ConanSandbox\Mods\modlist.txt file is missing though and you say you have been playing just fine… then chances are you’re playing without mods loaded and didn’t notice it depending on the mods you have. Maybe the server you connect to dropped their mods for this chaotic period?

You can check in your launcher or inside the game in the Mods section of the main menu to see which mods are actually loaded (it’s going to be the list on the right in the launcher or the middle in the game, so the ones that are “selected”, the ones on the left are installed but not loaded.)

Either way, if your game plays properly and it’s working as you want it then there’s no reason to “fix” it :smiley:

1 Like

Right, I don’t want to fix it if it’s not broken lol. But it is a server I run, and my mods are active (I runs stuff like Pippi and Emberlight so I would definitely notice that). But maybe they’re working fine since I manually added them? I dunno, just something I noticed and thought I’d chime in since someone else noticed their file was gone too. If anything happens and issues arise again, I’ll start with a clean re-install. It’d only be the 3rd time since 3.0 lol

And @Xevyr, I just wanna say thanks. I have followed u helping ssooooo many people with the update issues, including myself, I think FC should consider handing u a paycheck. Thank you, for all the help u’ve provided!

1 Like

Ah, I see :slight_smile:
I try :smiley: Though I’m certainly not expecting any paychecks for it anytime soon haha, they did give me this automated regular badge last night! But yea, the premature update was quite chaotic so I thought I have the forums open anyway I might as well try to make some people less angry and help them get back to playing if I can :smiley:

1 Like

@funcom - clearly the mod check/mod update functionality is broken. Please please fix it. It’s marked solved and clearly it is not.

2 Likes

I am having the same issue. Just posting here to make sure this thread stays at the top.

Epic games is a bit of a pain generally with mods as well I have to say.

What happens is that every time I restart the game it says “wrong version” next to the mod and has to download it again. So there are significant bugs here. This was not the case before 3.0 as I was playing it just recently.

Don’t make me sacrifice you for sorcery funcom dev team!

Just read this thread for the temporary solutions pls :smiley:

They don’t work for me as I use epic games. Every attempt I make fails. The issue is that in order to download mods I tend to need to download them manually anyway.

I have tried:
Deleting modlist, servermodlist and ModControllerCache.json after which verifying the game files.

The game does work if I let the mods download via the ingame installer, but the moment I restart it stops working. The problem is that I cannot efficiently download mods via steam, I cannot unsub.

In that case delete the physical mod files (the files your modlist.txt is pointing to)

I have tried all sorts of variations of this. Let me try to write out the procedure and you tell me where I am wrong:

  1. Delete modslist, servermodlist and ModControllerCache.json.
  2. Verify game.
  3. Download mods
  4. Update modslist and servermodlist to point at the mod files.
  5. Join server

Is that the procedure here?

Not really, verifying files does nothing for the epic version (the reason for it is because it forces a steam workshop update on the steam version)
And updating the servermodlist also does nothing as that is a temporary file exclusively used by the mod mismatch process.
Deleting your modcontrollercache while it’s nice if some of the mods changed could actually cause problems as there’s a scenario under which it will let you connect to a modded server without actually having mods loaded properly… So it’s always best to start your game in single player first with all loaded mods after deleting that file.

So in your case, what you should do is

  • physically delete your mod files (not the modlist itself as it’s pointless since you’re manually updating it anyay… )
  • manually download the latest mods used by the server
  • update your modlist manually making sure they’re in the proper order

If the server is also properly up to date then it should let you in… and yes there are currently issues so this very thorough attention required for mods is hopefully temporary. Best thing to do during this period is simply check your subscribed mods list on steam every single day to see if any of them has a new update date and if it does then preemptively delete and redownload that before even attempting to join a server.

Still trying but this fix does not seem epic games friendly really. I can say for certain though that this topic has NOT been solved.

This is a them problem and they need to fix it, not a mod issue. It’s an issue with whatever is throwing the sync between client and server. If it was a “mod issue” they would fail out on single player as well, this is getting beyond rediculous

1 Like

Is this still a “we’re working on this” situation?