Infinite Loading Loop

When I load the game and select the server to join, the game “loops”, heading to the mod update screen and reloading. When it comes back around, the mod screen loads again and the process repeats. I have to ctrl+alt+del to stop the process.

Any help would be appreciated.

2 Likes

I am stuck in the same loop. My mods match the server mod list and others get in no problem. Hell it’s my server so I’d like to think I have my game mod list correct lol

3 Likes

This is most likely caused by mods being updated multiple times today since it’s launch day.
So if you started the server and there has been a mod update since, the server cannot get the new version, but the client can… so you have a version mismatch, however your client has the updated version so there’s nothing to update, thus the process repeats.
Check version numbers on both the client and the server side and see if they match.

1 Like

They match and as I said other players are not having a problem joining

2 Likes

Try a verify game files on your conan installation, that should also force mod updates in case there’s an issue (sometimes steam just doesn’t send you updates even if there are some).

2 Likes

Did that too. No matter now though. I just went in single player and saw how much money you have to spend in the bazaar/battle pass to get the same items that were in the dlc system so yeah I’m out lol

4 Likes

I had this issue too. IDK what the cause is, but try unsubscribing from all your mods, launching the game with no mods and then immediately exiting it. Then resub to your mods and try again.

This is the issue I was having, for some reason the mod screen thinks your mods are up to date when they are not (Funcom issue) workaround is uninstall/reinstall your mods to make 100% certain they are up to date.

I’m having the same thing. I can log onto any mod-less server but whens it’s with mods I get the mod mismatch screen. All mods show as OK, the game tries to connect and then restarts back to the mod check.
Here is what I have done so far to try to fix

  1. Searched my disk for anything modlist.txt and removed all
  2. unsubbed from all mods, and made sure they were gone by again searching for the file name. 3.Deleted any duplicates
    4.Re-installed and deleted installation directory… Twice. re-verified more times than I can remember
  3. Resubbed to each mod in steam making sure versions matched
  4. Verified location were correct in game created modlist.txt
  5. When that failed. Copied all mods to a new folder and pointed modslist.txt

At a loss now of what else to try…

1 Like

Greetings Exiles,

Thank you for reaching out. Please make sure you have your mods disabled before starting the game.
We are aware of this issue and the current workaround is to delete:
Conan Exiles\ConanSandbox\Mods\modlist.txt will guarantee mods are not loaded.

Please let us know if the issue persists after performing the suggested steps.

2 Likes

Thanks for the prompt reply. I had already done the above and managed to log in to a server not running mods. It is when I try to log in to a server using mods(most of them) the issue happens. (see above steps I tried to resolve)

One thing I did to which made it different (just crash to desktop) was to create local copies of the mods from the steam downloads, unsubbed and deleted them from the steam workshop folder to be sure and then have a modslist.txt that pointed to there.

1 Like

Did you check your logs? The best thing you could do is to try to further narrow it down and see which specific mod is the one throwing the mismatch fit. Maybe there is something about it in the game log as to why the restart is happening. Once you identify it, it should be easier to determine why it’s happening

1 Like

Did you try verifying your files?
Again, I have seen several times that Steam gives you the A-okay and says that all your mods are up to date, however when you open the actual steam website and go to the workshop page of the mods, you will see a different version number than what’s in your launcher / in-game menu…
Steam is simply not pushing the updates so you need to either verify files and if that doesn’t work unsub / resub to those mods.

1 Like

Yea ofc! definitely needed to at least give modders a bit more time with the kit, but even the vanilla game is quite dodgy and would’ve benefitted from a few weeks more testing.

Also regarding this issue, several people seem to have this unexplained case of mods causing them infinite loops. A vast majority of them seem to be resolved by verifying files / restarting the server to make sure it has the latest as well as well as deleting the modlist text file to have the launcher remake it.
I do notice a few reports though that don’t seem to be fixed by these so I’m wondering whether it’s some specific mod causing it in their case

2 Likes

Same problem here. I have unsubscribed, subscibed to all mods, done a file checking, deleted the modlist.txt file… and still can’t launch the game. Endless loop. Makes me slightly mad.

Also, when you hit the “Launch” button, the game reacts as if you would have clicked on “Continue”. Most weird.

5 Likes

I am going to test this either delete the servermodlist.txt file or empty it before logging in. I think its been pulling that info. I am going to empty it personally.

You can hit the Cancel button when it trys logging into a server. This has worked and stopped my crazy loops and was able to log into an Official server where I was logging in a modded private server before.

1 Like

Sadly after all the work arounds and fixes suggested and trying every single one them I still end up in the infinite loading loop. It may have something to do with the mods but some other people I play with don’t have the problem so I am at a loss now until a patch to fix this comes out.

2 Likes

No mods installed, the problem persists

2 Likes

I have deleted this file and it still infinitely loops when attempting to connect to a private server that uses only one mod.

Same behavior as Infinite Loading Loop - #17 by Gang

This also did not help.

Sometimes that can be affective… but the CANCEL button on the attempting to join popup has always been and still is extremely unresponsive. The top-right window close button works if playing in windowed mode. Pressing the Windows key and then right clicking on the taskbar icon for Conan, then selecting “Close Window” works. And of course ALT+F4 will also work.

1 Like

Hello @theNexusRI

I had this happen on a server that only ran 1 mod. The simple solution was to unsubscribe from the mod and then load the game and allow the mod to be updated via conan exiles. Worked like a charm!

1 Like