Item disappear from chest

Game mode: Online private
Type of issue: Bug
Server type: PvP | PvE-Conflict
Region: europe
Mods?: Yes
Edition: steam

Bug Description:

Hi, i’m the owner of a rp server and something weird happened to two players.
-After a restart server, one of the player on the server told me all his panther disappeared from his animal pen. I went there and checked by myself his base and his event log, no panther. Then the server restart again and they were back in the animal pen.

-A player stored his stuff in a chest and after a restart everything disappeared from the chest. I checked the log too, but nothing. We thought it could be just a graphic glitch, so he tried to take this chest in his inventory, but his stuff was lost.
-An other player stored multiple items in his carpenter’s bench and his chest. After the restart they were empty, and more the carpenter’s bench had “no owner”.

Installed Mods:

Nameplate Off
NoSlave Bracelet
ExpandedMap Curse Wall removal
Dudes Delightful Decorations
Ooga Booga Mod
Ravencrest Couriers
Less Building Placement restriction
Improved Quality of Life
A more complex way to remove
les mines d’or
Better Thrall
Thrall Nerf
Immersive armor
Barbarian Barber
RA: character Customisation
Devious Desires

Steps to Reproduce:

Please provide a step-by-step process of how the bug can be reproduced. Please be as detailed as possible; the more details, the easier it will be for us to find and fix the bug:

  1. Step 1 Store something in a chest
  2. Step 2 restart the server
  3. Step 3 Maybe it will disappear
  4. Etc.
1 Like

Hi and welcome to the forums :slight_smile:
Just thought I’d add a link to a related report thread (where two of us have had the ‘reappearance’ occur, but others haven’t - so may or may not be the same thing). There’s also a link from there to a playstation thread, where the ‘no owner’ aspect has been showing up. I’ve no idea what the triggers are, but it seems like all these threads are related…

1 Like

thanks for the answer. I think it’s the same bug, when the player lost his items it’s when he tried to grab the chest in his inventory. We will try to not touch the guilty chest. Apparently only the chests placed after the 2.6 have this bug.
I will keep looking on this mystery.

1 Like

I can confirm the following situation: after latest DLC patch, created a new saddler’s workbench, place a thrall and made a whole bunch of saddles in there. Walked away from the base, came back and the items all disappeared. More interestingly, rebooted the game, the items and thrall reappeared. Played for a bit, rebooted the game, fresh boot, loading into that same base i always park at, items disappeared again. Now I can’t get them to come back again. This is a serious issue. FULL VANILLA GAME, zero mods ever. (Also, on a side note, since that same patch ALL saddles have lost their color, they’re just all this ugly blue-lavender color now)

1 Like

Hello! Based on the reports in this thread, I’m hazarding a guess this is a known issue where the server occasionally does not load everything up from the game database on startup. The items are not actually gone; they’re still in the database, but on each reboot/startup of the server, it is possible that some items may not load in.

We have a fix for this committed in an upcoming patch, likely due next week.

Edit 10/30/2021: The patch may not arrive this coming week. Will keep you posted.


i’m curious what will happen since i picked up the workbench while the items and thrall were “disappeared” and placed it down again. i’m guessing my items and thrall will be gone. sigh…

1 Like

Okay good cuz im experiencing this too. Wierdly it teleported object from one wheel of pain into another one i built in the same place.

I’m curious… Will the fix you mention work for single-player as well?

I’m not playing on a server, but I have been experiencing this issue in SP. It’s super irritating when all the contents of my WoP just vanish. The ownership is also listed as ‘no owner,’ which is obviously not right.

I imagine it should. As far as I understand it, it’s an issue with the server not loading everything in the database - shouldn’t matter if it’s online or offline. Will ask Monday when folks are back on.

Oh, it should also be noted that the update may not arrive this coming week like I may have implied. Sorry about that. Will keep you posted.


I’m missing 6 chests, and their contents. The ones with my most important items in them of course. Nothing in the event log shows them as being decayed or otherwise. My base is completely intact, and I play PVE-C so I know it can only be related to this issue. Has anyone else had both the chests, and their contents just vanish?

Thanks for the update Andy. Dates aren’t as important as communication, so thanks for letting us know and do keep us posted!

Better a good patch that fixes bugs a few days later than planned than a rushed patch that causes more bugs than it solves.

1 Like

The contents do come back eventually if you leave it alone. In my experience, if it says ‘no owner,’ the previous contents appear missing. Meanwhile, anything you put in while it says ‘no owner’ will be gone when the ownership is eventually reestablished(and the original contents get restored). Also: if you pick up the container while this is happening, you lose everything, so don’t do that.

Really hope they get this fixed in the next patch, since it’s super easy to lose items if you don’t realize what happened.

Unfortunately, if your chests are also missing and not just the contents, then it sounds like you may have suffered from a different issue - as reported here and previously:

I hope I’m wrong, but it does seem like it may be the case.

1 Like

I didn’t see Andy’s post until now. His post agrees with the observations I have been making that the issue is related to server restart.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.