Loot All function no longer working

Game mode: [Online]
Problem: [Bug ]
Region: [USA]

After the June 15th update using the “Loot All” Function by pressing F to pickup all items has stopped working.
I’ve restarted my game and connected to other servers and the issue persists.

Steps on how to reproduce issue:

  1. Kill some poor ■■■■■■■
  2. Target Corpse
  3. Press F (loot all default)
  4. Be sad that you didn’t get jack.
1 Like

I’ve seen a couple reports around this, and have noticed it myself with any container. Even opening a container other than my own inventory, crashes server connection; crash to main menu.

Even if your keybinds are default as it is, change your settings, save your keybinds, then reset to default. This has helped fix it for a lot of people.

I’m assuming they changed how loot-all is keybound in the INI file and old INI files are causing this error. Resetting your keybinds to default wipes out and resets that keybind section of your configuration file.

1 Like

Thanks, @Leon, I will try this today. Would be good to find out for sure if opening a container causing C2Menu is coincidence, or this might fix it.

I have the same problem. But it’s all the shortcuts when we want to loot which don’t work.

I pressed reset to default and that did nothing.

I also don’t see an option in the settings to change the loot all keybind.

Change your keys to something temporarily. Save. Then reset. Any difference? This process worked for me.

Tried here, and no dice. It seems to be an issue very specifically with the “use” function, AND the keybinding system…? When I tried to change the keybinding while in game, got instantly kicked to menu, and server ‘burped’ - ie; high CPU spike, for 30 seconds or so. 1-2 minutes and server able to be logged into again.

Obviously, could be mod related. Wondering in fact, how many of us are using the Immersive Loot System.

1 Like

Cross-post, fyi.

Found a clue on the inventory/F key not working/etc issue… it looks like, there was a last minute change made to testLive, before the whole patch went live? That would mean that this edit did NOT go through the same amount of testing as anything else in the patch did.

“Exploit fix: Fixed a problem with stack merging logic which could allow for item duplication for certain equipped items”

I will remove my stacking mods today, to test whether this is where that issue is coming from.

Remove any item stacking mods you have.

I had this issue and do not use mods, so I think they may be unrelated.
Changing keybindings, saving and then resetting them did not help.
(This action actually wiped out most of my input.ini file’s contents, luckily I had saved a backup.)

But I did find one sort-of-solution.

Changing the keybinding to anything other than F using the ini file fixed it. I could use the new binding just fine. But if I changed it back to F, it stopped working. I explain it here:

I changed the binding to O and that let me loot corpses. I clicked to reset bindings to default and could not loot the corpse with F.