Memory Leak(s) lead to Low FPS and Micro Stuttering

Main System memory usage climbs over time, with FPS drops and Micro Lag/Stuttering
North America

Suspected Memory Leak(s) causing FPS drop and eventually micro lag / stuttering effect.
Here is one of my time / memory usage notes. First started observations when I noticed the FPS drops and Micro Lagging / Stuttering effect

08:59 Boot system* 2.6 GB
09:04 Steam and Conan up, in game 7.0 GB
11:36 Noticeable FPS drops 11.0 GB
12:21 FPS dropping further, Micro Lags show up 12.0 GB

*includes VPN, Anti Viral and other system stuff plus utilities for keeping track of memory usage/temperatures, etc, + a browser.

I usually re-start Conan Single Player when it starts to get to low a FPS, Micro Lag stage. I didn’t hang in there until the game actually froze and crashed my system. Seemed inevitable but with 32GB of main memory I didn’t want to suffer that long.
I have been keeping performance records of this problem for awhile now. I just shell out and check memory usage and temps every once in awhile.

I have been writing this as I am WAITING for a meteor drop. This actually caused me to miss seeing where a couple landed. Only found One and that was because it almost hit my watch hut. Been in game for less than an hour (6 minutes less actually) and the Memory Usage has already gone up overall by 1.1 GB

Please provide a step-by-step process of how the bug can be reproduced. The more details you provide us with the easier it will be for us to find and fix the bug:

  1. Start single player game
  2. Periodically Check System Memory Usage.
  3. When it reaches about ~9 GB usage just for the Steam/Game/Server (subtracting boot & utility usage) it’s frame rates are reduced and it starts Micro Lagging.
  4. Restart Game and play some more.

This will take someone about four hours on a good rig to get to this point. I haven’t tried just letting the game run for four hours while not playing it.

Windblows 10 with latest updates / just for gaming
EVGA 1080Ti SC black NOT Overclocked
MSI x99-a motherboard with latest bios
Intel i7-5930 socket 2100-v3 overclocked to 4.2 GHz (stable at stock power settings)
CORSAIR Vengeance LPX 32 GB (2666 MHz stable)
Coolermaster Nepton 280L CPU water cooler (never gets over mid 60’s degrees C)
Samsung 850 EVO 500GB (not in raid)
Cooler Master HAF X case
EVGA 1000W platnmum power supply
Samsung u28e590d 4K monitor

I run Conan Exiles at 4K. Mostly ULTRA (NO Anti Aliasing and Low Shadow settings)
FPS in the world is at mid 50’s to 60 (max for the monitor) At the Base, with the current settings, it is in the 40’s. At the base Memory Leaks cause it to drop into the 30’s and eventually down to the 20’s.


Just did a sitting around watching dancers, test.
No change in memory usage. A 1 FPS drop over an hour. Right up until a change in the weather then my avatar’s white hair got darker and fps went down to 31, with the same view of the dancers.

Then went around accessing inventories of work benches, storage boxes and NPC’s.
After accessing several in less than 5 min. there was a .2 GB gain in used memory.

The inventory access subroutine is a place to START tracking down memory leaks.
Forgetting to DE-allocate (UN-allocate) memory on the way out is one of the usual suspects.

1 Like

I also encounter this bug. Game usually between 12-15 gigs of RAM used.

1 Like

I usually stop when the micro Lags / Stuttering shows up. This is usually a sign of an impending system/game crash/hang coming. At right around 11 GB of memory used, total.

I am now more than convinced that there is a problem in the inventory access sub-routine.
Definitely a memory leak in that particular module.
Such is life with procedures using library calls written in the Key of ‘C.’

1 Like

I am on the release version, not the Test Live. Maybe the problem got fixed in Test Live.

I did a sit down and watch dancers test. Nothing changed memory usage did not climb for about an hour. Then a storm came in and FPS dropped about 10 FPS.
But when I ran around accessing inventories the memory usage climbed.

Sure I am running mods but they have to use the libraries that FunCom gives them. Therein lies the suspected problem.

Frame rates are fairly consistent, but drop slowly, until the Conan server/game memory usage gets to just above 9 GB (about three times what it should be) then micro lags (stuttering) show up with very decreased FPS. It may be a WinBlows 10 issue with the database… I will try repacking and re-indexing after running a few errands.
Did the database check/cleanup/repacking/re-indexing NO CHANGE.

1 Like

This topic was automatically closed after 7 days. New replies are no longer allowed.