Missing categories in Feats menu


#1

I bought the game and created some toons about 3 days go. It took me some time to figure out how to start building stuff, and apparently it is because my toons do not have in their Feats menu the whole Construction category at the top:


No “Construction” at the top as I’ve seen in other people’s screenshots. No Blacksmith, Carpenter, etc. If I search for “Mason” then I see the proper feat in the results and can even learn it. I do get the corresponding recipes in the Inventory window and can craft them, but the Apprentice Mason Feat still doesn’t get displayed in the list of Feats.

Also, if I want to learn Blacksmith for instance, I can click on Weaponsmith, see Blacksmith as a requirement and click on it, then it appears on the left pane and I can learn it as well.

This happens on a solo character as well as online. Just tried creating a new solo game and am still seeing the same issue. I’ve tried having Steam verify my files and everything looks OK.

Needless to say, I cannot play characters on which I do not see what is available to be learnt.


#2

I’ve asked people on the server that I am on to create a new toon and see if they are broken too and they are. It appears that new characters created in the last few days are missing many Feats in the left pane display.


#3

There are some new developments. I’ve learnt some of the “hidden” Feats through the Search button. Suddenly the Construction category appeared, others not:

But at the same time, 6 new “items” became available to be crafted, empty icons, no description, etc.:


#4

What happens if you click the actual construction tab?


#5

Concerning the 6 empty recipes, today the game is showing recipe ids it the tooltip. In case anyone cares and wants help debugging this stuff, the IDs are:
390150
390153
390156
390215
390216
390221