New engine with low texture QL

sup everyone.
Ive tried the guide from Caloss2 " Anarchy Online 18.8 “Fixing” The New Engine".

But I cant run AO with the new engine on my Laptop with high quality textures.
its always been on low settings.

(please copy and set the dot after imgur to see my screenshot)

as u can see the BP, signs, … the whole textures of characters r in Low Quality … and I dont know y.

what I found:

settings wont show my gtx 970m! may this will be the prob ?

Im running AO correctly.
This wont happen on my desktop PC.
can some1 help please :frowning:

got damn guys … what kind of bad Forum software is it …
as a new user I cannot post any pictures? oh sick …that suxx so hard

Sorry to say that AO has a long history of struggling with laptops with dual graphics cards. The solution seems to vary quite a bit.

Some suggestions I’ve found include:
Option A:

  • Right-click the AO shortcut
  • Run with Graphics Processor
  • High-performance NVIDIA
  • Settings -> Visual -> Rendering Device (Change) -> Primary Display Driver - Direct 3D T&L HAL

Option B:

  • Copy over preference from the old engine (which has the correct GPU setting)

Option C:

  • Go into the bios and force the discrete GPU to “fixed” rather than “dynamic” (although this may significantly reduce battery life)

thx for ur reply.

I would like to try option c at first. reduced battery life is no problem. Im always pluged in

thats the bios advanced setting wich one Ive to change ?

Sorry, I’m not familiar with the specific settings for your particular laptop, so hesitant to provide something that sounds like an authoritative response.

There should either be tooltips in the right hand sidebar when you select each option or your going to need to find the manual for your device. What you are looking for is the option that doesn’t revert to the integrated GPU to save power.

I’m not familiar with your BIOS either, but my guess would be to set the option “MSHYBRID or DISCRETE Switch” from “MSHYBRID” to “DISCRETE”. That should mean that your laptop will always use your GTX 970M (discrete GPU) instead of switching between your integrated (Intel HD 530) and discrete GPUs.

thx to u both! one thing changed Ive switched to discrete and I think we r getting closer to it.

the 970m shows up now. but low textures r always there ingame

any other clues ?

btw: here is what the old client looks like. as u can see there r high textures

option B wont work
option A is not avaible

No ideas guys?
Maybe Caloss2 anything else? :thinking:

I had a similar problem on my laptop. basically those mobility gfx cards only tun on when they are needed. I think it has to do with what version of directx ao requires. there was a way I was able to get the old client to work with my gtx 960m by masking the dx as a more current version but it also caused the game to crash frequently.

In the end I was not able to run the old client with my 960m but Instead used the settings for the intel cpu to smooth the edges (simulating anti aliasing) and the game still ran over 60 fps and looked fine in my opinion.

I would suggest trying to run ao on a more current version of directx, since this solution has worked for other old games in the past. look around for a way to mask the old version of directx that ao uses as a more current version. If you have success doing this I would be very interested because then I would be able to run AO better on my own laptop.

other things that I tried which did not work: using nvidia settings to select “always use gtx 960m” for anarchy online. This has no effect. maybe it will with your laptop but it never worked for mine.
updating my drivers. going into my bios did nothing because, like yours, the laptop has an integrated gpu. the manufacturer doesn’t allow for much customization in the bios with those.

For troubleshooting purposes, can you run the game with Task Manager open, showing GPU utilisation graphs.

As you have two GPUs you should be able to see which is taking the load. If it’s your discrete GPU then we can probably be satisfied that that’s no longer the issue.

Edit: also how much vram does your GPU have?

I don’t think this is related to which video card it runs on, but a separate problem. It appears to be the same issue as in this thread, and the posted specs have a single card. Unfortunately there doesn’t appear to be a known solution.

AO needs huge update with many things and will be even harder next future,this is one of them.
I bought laptop 1 month ago and took me 2 days to be satisfied with graphics but not what I would want.

One thing you can try is disabling your Intel videocard under Devices Manager. BUT BE AWARE, this will lead to many weird behavior under Windows and you might have to enable the Intel graphic card when you are done playing the game to prevent problems under normal work in Windows.