Quick way to improve graphics (Steam/old engine)


#1

PLEASE NOTE, exit the game before doing this.

This an AMD graphics card guide but this can also be done on Nvidia graphics cards.

If you’re playing the game through steam or running the old engine, open AMD Radeon Settings (right click desktop) add the AnarchyOnline.exe found in SteamLibrary\steamapps\common\Anarchy Online.

Under Anti Aliasing mode, select Override application setting and for Anti Aliasing method select Supersampling. You can try the other options but for me they caused glitches on the hotbar and planetmap.

For Anti Aliasing Level select x4. If you’re using a laptop or old computer and you get low framerates then try x2. If you plan on triple logging or dual logging you may experience framerate drops at x4 even on a good computer. Anything more than Anti Aliasing x4 at 1920x1080 is not really noticeable.

Under Anisotropic Filtering Mode click it once and it should say Override application settings. Then click Anisotropic Filtering Level and select 16.

Click Texture Filtering Quality and select High. Click Surface Format Optimization and select Off. The end result should look like this, it makes a world of difference!


Bad performance
#2

Could you post before and after screenshots?


#3

@FormlessBlackVoid





#4

For invidia using the old engine.

You’re welcome.


#5

I sooo wish I could do this. After over a year playing on my gigabyte sabre 15 gaming laptop I still can’t get ao to see my gfx card :frowning: the on board one works ok but framerate sucks compared with what I know it could be.

Had a few sessions trying everything recommended and never succeeded. Bios won’t let me turn off on board Intel one. Can’t force it through Nvidia control panel. I created a virtual machine with Windows 7 but the VM wouldn’t allow full access to gfx card, “playthrough” I think it’s called. dgVoodoo is the only thing that works but at best lasts 30 seconds before crashing, it was beautiful cruising around with 100fps but I just don’t know how to stabilise it.

Next time I’m bored and frustrated with I think I’ll try the new engine and hope I’m one of the lucky ones that gets reasonable stability with that.

Thanks for the info posted here and all your vids caloss!


#6

I’d try the new engine.

I know for the majority of people it’s not working, but I’ve got this…

…and it can’t or the life of it seem to run its MX940 with the old engine properly. The frame rates are below 20fps with the old engine, and while it’s pretty clear the new engine has some issues with the Nvidia card, instead of 20fps in Old Athen with the old engine I get 30-40 fps in Old Athen with the new engine. Maybe a bit more, because the old engine seems a bit like trying to dance in treacle on the old engine.

That said, the new engine will, for me, crash occasionally wherever there are whompa effects/textures to load.

It also loads pretty spiffily. I’ll sometimes in cities and SL temples watch walls and items load into existence after zoning while I’m happily running around (this is probably more down to having single channel RAM due to waiting out memory pricing/not really caring much.)

This is also what my options look like after mucking about with @Caloss2’s suggested Nvidia shenanigans. I can assure you, it’s my dedicated card working with these settings. It gets agitated, hot and bothered.


#7

That seems very strange you get 20fps on the old engine. I find its easy to run on just about any computer these days. Do you have Vsync enabled? AO with Vsync is horrible.

If you’re still getting low framerates, try lowering your view distance


#8

It seems. No Vsync involved and all the old tricks, etc. I just spent a while messing with the old engine (reinstall), which after setting profiles and messing with other settings left me with the conclusion that the graphics card just doesn’t want to co-operate with the old engine.

:man_shrugging:


#9

Primary display driver is the on-die intel GPU. Not your nvidia GPU.
Use the nvidia inspector add AO to something like 3dmark 2004; scroll down until you find “enable for optimus” and enable it. Dual graphics systems coding in windows will choose that AO is not a 3d application every time until you tell it otherwise.


#10

If it’s

0x00000001 SHIM_RENDERING_MODE_ENABLE

then it’s already that way from when I set the profiles way back when. :confused:


#11

0x0000011 (Autodesk showcase, monster hunter online … etc


#12

Oops. Yes, I see now. It gave the new engine a tiny boost (perhaps), but the old engine still doesn’t grok it. With that said, I’ll stop trying to wrap my head around the old engine for the sake of everyone’s sanity. Several reboots after changed profile options, a clean install of graphics drivers (Display Driver Uninstaller and the whole dance) and setting the discrete card as the default global graphics card didn’t seem to work, so thanks to both of you, but oh well. :slight_smile:

Edit:

I haven’t crashed once after you corrected me on the Optimus setting. Gg!


#13

I did this but im not seeing the 0x000011 entry, it’s just a blank space in that spot between 0x000010 and 0x000012

Also I’m trying this on the old engine with a laptop with a 1050Ti, I guess it wont work with the old?


#14

Yeah pretty sure that’s only for the new engine but I could be wrong


#15

tried forced aa with an nvidia card a while back. i remember it killing my framerate, especially if multiboxing.


#16

Vsync enabled or no Vsync?