Noxious gas/sandstorm mask bug

Game mode: [Enter game mode here: (Online official |
Type of issue: [Enter one of the following: | Bug |
Server type: [Enter one of the following: PvP |
Region: EU

.After the new patch,cant protect myself agains noxious gas ,while farming brimstone,or against poison arrows. I tryed with sandstorm mask,setite mask,commander helmet,witchdoctor mask,and noone worked… I reinstalled the game too,i fixed the files too( ofc everything was okay), and dont know what to do now. Please find a way to fix this. And ofc everything is okay for my mates :smiley:

Have a nice day

maybe @Ignasi you guys know something about it?:slight_smile: Ty <3

did you try removing your bracelet? it fixes all sorts of bugs

yes ofc :smiley:

If you equip your mask after you enter the gas area, you will still be hurt. You need to leave the area, unequip your mask, then re-equip. With your mask on once you enter the gas area you should be good to go. Just did Shattered Springs.

1 Like

ty mate,but i know that too :smiley: i have more than 4K hours ingame,and cant find out what the problem… :confused:

Okay, good! Can happen to the vets among us. :wink:

Hello @Osi, thank you for reaching out!

As Barnes has stated, you’ll have to equip the mask before entering the gas areas, could you please confirm that no mask is working after trying it out following this exact procedure?

1 Like

yes ofc :smiley: i tryed everything now as i said :slight_smile: and nothing worked. and i tryed with all the helmets/masks. as i read before, im not too newbie,soo thats why im upset cause cant find what the problem :confused:

and i changed the helmets /mask at home,before i shoot a poison arrow too,then walked in the gas,and im getting the damage

then i started again with another ,ofc i waited until the cloud dissaper ,and nope,not working

and the really strange is,that for my mates ,everything okay

What I can tell you from my farming the last few days at the Volcano: If you swap ONE gas mask with another gas mask, you dont get the gas mask protection!!
You have to swap to sth, which is NO gas mask and then to a gas mask (at least, it was like that last week).


ty mate,i will try it,and reply ofc :slight_smile:

cause im always in gas mask XD so i get a non gas mask first

okay.Soo @Hugo

I logged out in sandstorm mask,and went to brimstne lake. i tryed to farm it ,and i said the problems before.
BUT. Thanks to @jot29 , if im using a “normal” helmet before i put on a sandstorm mask,its working. But i think thats not the ordenary way soo :smiley: but anyway thank you guys for the faast reply,and dont forget this if you have the same problem too! <3


Hrhr :wink:
Discovered that some days ago, while killing some stuff with my Set mask and swapping to my Witch Doctor Mask (gives +10 survival, great for farming). The witch doctor mask is a legendary armor piece and therefore, I didnt want to fight with it (because you couldnt fix it, until the patch arrived with the legendary armor repair kit)

And suddenly I get dmg from the gas there… Then I looked at the left side and the gas/sandstorm-mask buff was not shown. At first I thought, the “nerfed” the Witch Doctor mask. But after swapping back to Set, the buff was still missing…
Then I tried swaping with my normal helmet and suddenly the buff was here again.

You are also not able to swap the SAME weapon (at least at PS4). It will say, that your storage is full… For example you have a steel sword and its near to broken and you have another steel sword in your inventory. Even when it is unequiped (but in hotwheel), you cannot swap it.

Hey there,

We’re going to poke our team about this just in case there’s some additional issue we might be overseeing.
Thanks for your feedback.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.