NPCs are invisible, villages are invisible, the whole map is invisible

I play on a PS4 Pro, hard wired, external SSD, internal SSD, and the actual game disc.
We are also on an official server.

2.3 slowed the render time for builds. It was fine, but I had to wait a minute or so for the base to fully render, or at least for a door to appear.

2.4 slowed it even further. This is 5 minutes after I arrived

For the past week, I haven’t done much online. I have just run around a little. Several times I have run up on the edge of where the map has yet to render. I did it twice on horseback, so I tried to just run. It didn’t help.

This is on the river running east to the Sentinels

This is running west towards the Ward Towers

Not only am I waiting for buildings and the actual freaking map to render, NPCs aren’t rendering. I have been killed 4 times today. I’ve never died four times in the same month. The people I play are usually surprised when I say I was killed.

Three times, I was pinned against some structure I couldn’t see, attacked by NPCs I couldn’t see. Once, at the south jungle obelisk, I went to fight the panthers, and my axe never appeared in my hand. I was holding my hand out like I had it, but it never appeared, and I couldn’t attack. Add to that the panthers glitching around from spot to spot without moving, and 6 bleed gets to be a problem. Even the gorillas got in on the stutter moves.

The game also freezes whenever I run up on a build. I have regained the ability to move just in time to be attacked by things I normally ignore.

I lost a thrall from a build. She was stationed inside. When I went to investigate, all 5 thralls from the inside were outside, having moved on their own. This is happening all over the map. I find thralls have moved to new locations.

@Hugo @Ignasis , this is a serious issue. The last patch renders the game no fun. If I’m not having fun, I’m not playing. At best, I can run to my bases and reset the timer, but that’s it.
I will do that because our clan has almost three years on the server. We have amassed quite a bit of stuff.

I hate the overuse of “unplayable”, but this last patch brought us to it.

4 Likes

2 posts were merged into an existing topic: 2.4.4 has ruined the quality of textures which the PS4 Pro can handle. It was just fine before the patch

Merged thread with the one mentioned above to increase visibility, as they stem from the same issue.