PC - Equip Light Armor Bug

Not for me.
Had daftari and the default light armour , nothing

I think I tried every armor by now.
basic light, darfari, shemite, thief, bucaneer (that epic only), vanir, second shemite, dancer outfit… even both climbing gloves and boots… sandstormmask as well…
Nothing worked for me. (Official server; #1043)

The problem with bugs is it wont affect everyone. Thus some people tend to say the ones with the bug must be missing something, have done something wrong.

It seems I cannot even change the language of the game. I do know where to do so in steam (properties of said game, language, dropdown menu -> english) but it wont apply.
When I let steam run over the files to verify them, that didnt change.

that’s exactly the issue, the language of your game-settings, maybe also the language of your OS may influence this journey step.

For instance, a mod is the only reliable solution right now. Maybe there will be some correction later, maybe…

Not really. It has nothing to do with the game or your OS. The problem is with the host language. How is that different you might ask?

If it was dependant on your own game or OS language setting, then you can circumvent the problem by changing your game or OS language.

However, this is the host language, which means the following:

  • The issue will be present if you play single player or self-host a server on your OS and your OS/Game is in Non-English Language
  • The issue will be present if you play on a server that has a non-English OS/Server setting regardless of your own OS/game language.

So a mod is fine for single player, however if you are dependant on an official server, there is absolutely nothing you can do about it, there is no fix or even workaround. As the mod explains, the light armor journey seems to make a direct name check, wheras the other journeys use an item ID match. This should really be adressed with a hotfix, as it’s not something that needs to be re-coded as the function to make id matching exists as we know from the working journeys, they need to change the calls. Unless the working journeys are more of an oddity than the non working ones (maybe because armor names are not translated)

1 Like

nice analysis, tks !

For my part i play all in english. Not because it’s my motherlanguage, but because it’s makes informatic so much easier to me.

So i’m hearing about that bug mostly only through others.
The OS is mentionned in a mod fixing the light-armor journey bug, but i never investigated further, i admit. There would be lot to test, different pc’s, config and so on of course.

I had this problem triggering a while ago when the game was still in early acces, and in SP. Since i changed lot, my personal pc-settings and lot more, and not have to bother with this error now.
I think for those willing to use a mod is easy to trick the system, and maybe there will be a fix in the futur.

Confirmed to work on Private Server. As test I backed up the current server and started a brand new game. Admin cheated in a Light Chestpiece then equipped it (I was bare chested but had on cloth sandals and leggings).
English is on Server and English is on Client

I’m a little stuck. It seems the issue is if your server isn’t set to English and, if not, to change it to English, and most comments seem to imply people are running their own private servers. But as I’m playing on official server (www.battlemetrics dot com/servers/conanexiles/2244077), which appears to be English already (at least it shows the UK flag for the country) and I can’t touch the server culture even if it weren’t, as it’s an official server

Any other ideas? Is there a way to log this through support? It’s really annoying not to be able to see the higher level journey quests in game…

They are aware of the issue, and a fix is in the works that is due to release next week. Below is a quote from their patch release from today.

Also a quick note on the infamous “Light Armor Journey” Bug. The fix for this will go to testlive with the over 500 additional changes that is scheduled for next week. We know that you have been waiting for this for a while and we apologize for the delay!

1 Like

did you try yet the sandstormmask ? this seems work for most people having this issue.

No light armor works for me. I think I literally tried every single light piece… Thus sandstormmask wont work for me as well…

i’m realy sorry to hear that. I know it depends settings and people.

If you’re willing using a mod, you can fix it easily. Without we have to waite and hope, that’s.

I didnt want to verbally punch you to a pulp, I just wanted to point out how using sandstormmasks might not help everyone. (Probably even helping only half or less people…) Other than that, “unfortunately” I am playing on official… :wink:

Actually there might be more problems causing this light armor bug.
i.e. I cannot really change the language via steam. I can hit english in the drop down menu but it will keep starting in german… :confused:

But fortunately they seem to adress this bug in the upcoming week. All fingers being crossed here! :slight_smile:

2 new players playing together, official EU PVE PC server neither of us can complete the equip light armor journey step despite crafting and wearing light armor pieces.

Are you kidding me? This is an officially released game, but there is more bug in it than during early access! Ridiculous! when there is already a repair, since the last update, there have been errors with hundreds that have already solved the solution! It’s a joke category this whole game! Joke category is Funcom!

Just wanted to point at this:
Equipping this light dlc armor worked perfectly for me and my clanmate. German clients, official EU server(s).

If people paid attention, they know its fixed in next patch :wink:

Can you tell me where to find that information please as I read the latest text patch notes and I can’t see it.


OK i see where it says fixed on testive ty. I had looked at the 28/06 patch notes but had not seen the list you linked. Still finding my way around.