Playing with the update

so radial menu is annoying when decorating. the " sticky" feel is not smooth.
went to UC, tried fighting the dragon, which normally is bugged for me as my thrall is always getting slammed into the foundations and all i see is her head, she doesnt attack , and aggro is on me…kinda defeats the purpose of bringing a thrall…my work around is to run far away till she comes back to me and do the entire process over.
after the patch today, after spending quite some time trying to find the server i play on since it is always taken off my favorite list…( next patch…)… i was excited to try these new attack commands.
well it says on the screen i told my thrall to attack…but thats not the case…she stands by my side and does not move…no radial menu used for aggro limits or anything yet was done at this point. so the dragon as normal stood still not attacking …my thrall is 2 feet away not attacking…even though im now smashing the button out of frustration lol.
on my way to the dragon however , she attacks everything on my map…stuff i was just going to avoid.
on the bright side the servers seem smoother…while i was on …since 5 minutes ago i was disconnected from the server…so maybe next patch?
i know you do hard work on this gem of a game, but maybe we could slow it down on dlc focus , and really work on what you already have.
theres so many fixes that need to be done…in the next patch.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.