Please fix the authentication server

I can not login to manage my account at and I am getting " Authentication failed, please check your password and try again" error. My password is correct because I can log in to the game. I have tried as well.

The problem also occur when trying to login at with Sign in through Steam button.

Game Password and Account password can be different. Logging in game doesn’t necessarily mean the account password is the same.

It worked 2 days ago . I did not change my passwords since then . I have tried to access the master account management page from several accounts with the same results “Authentication failed, please check your password and try again” . And as I said when you log in to with Steam button, you don’t have to type in the password because the authentication is done by steam api - yet it gives me the same password error.

Edit: I did password reset (just in case) and still can not log in with the newly generated password.

It’s not the first time the authentication to master account is broken. I have encountered the same issue about 2 months ago. I couldn’t log in to my account for about 2 weeks then suddenly it started working and fixed by itself. It’s sad because I just bought the DLC packs from Steam and wanted to activate the keys on my account and I can’t :worried:

Okay so I digged down deeper and found out that Funcom (for some unknown reason) has blocked logins to the master account management page (www) from my home cable ISP IP.
I connected from mobile phone IP and it went thru. After that I reconnected back to my home ISP and I can now log in to the account successfully.

Anyway this is not how things should work…

The issue is back. I can’t login to account management page. I really want to know what is the reason behind blocking logins from my IP every second day.