Problem upgrading talisman

Attempting to upgrade a green lvl 19 waist talisman with a distillate suddenly costs 800 (instead of 200) and gives a very peculiar message instead of the new stats.

Attempting to update the same talisman with another talisman of the same type has the same result.

All upgrades which do not involve moving a talisman from green to blue work fine.

Are you talking about empowerment or fusion? Those are two very different things and the latter can only be done with two max level items (level 20 for green, 25 for blue, 30 for purple and 35 for yellow).

A screenshot would help.


I’ll try to get a screenshot later today

OK, logged on. Just about every window you can create on the system was open (including one or two I swear I have never seen before) but when I tidied all that up empowerment was working correctly on the item which had been causing issues before.

If it happens again I’ll take an immediate screenshot.

Sounds like you had more empowerment items in the upgrade window than were necessary to max out the item and the window just wasn’t rendering properly. Normally the game would highlight the unnecessary items to prevent you from wasting them.

SWL empowerment warning

Unfortunately the upgrade window is notorious for turning items invisible. This often causes people to think that they’ve lost items. Relogging or zoning tends to fix that, in case it happens again.

Nah, it wasn’t that. Where your window has lv6 > lv20 Shotgun mine had something like lv19 > lv2 and (19 in green and 2 in blue) and something about 150000 XP. Plus nothing appeared in the stat changes window. It was totally loopy and I tried several other things before I gave up. I suspect some sort of localised data corruption but it was not a passing thing as I actually logged off and back in. If it ever happens again I will take a screenshot immediately.

Thanks for the suggestions, though.

You really should have gotten screenshots for that. If you did, you should add them here.

I think it rather obvious from the prior discussion that I did not take screenshots and am aware that in future I should do so.

I guess we’ll see lmao.

See what? Your first post here was unhelpful. This one appears meaningless. Or are you trying to boost your post count for some reason?


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.