PUA/AD.CoinMiner.apdz malware alarm after patch

Game mode: [Enter game mode here: (Online official | Online private | Single-player)]
Type of issue: [Enter one of the following: Crash | Bug | Performance | Misc]
Server type: [Enter one of the following: PvP | PvE-Conflict | PvE]
Region: [Please enter your server region]


[Describe the bug here]


After Installing the hotfix and restarting the game my Avira Antivirus quarantined a file since it detected the malware
PUA/AD.CoinMiner.apdz
in the file
STEAM\SteamApps\common\Conan Exiles\Engine\Binaries\ThirdParty\GraniteSDK\Win64\release\grGranite.dll

False alarm or real danger ?

2 Likes

It looks like false detection, but Funcom should solve this problem with Avira.

Cannot post a link here but you can recheck it on virustotal[dot]com by uploading this file or by hashcode c16306502110a1f7e1290344e922ee7e9aa51bda988efd9e2c2c8aa02dc9a09a

This is one of the many reasons why you should always exclude your game clients from security software.

Actually, it’s a bad idea. Game developers are humans too and they can do mistakes (accidentally or deliberately). There are a lot of possibilities to deliver viruses into your PC (and games are no exception).
Ex. developers could get already infected dll, someone could inject a virus into dll, someone could hack their build servers, etc.
I have already begun to doubt cuz after update the game works worse. I have some freezes, FPS drops and my GPU loaded on 70+ %

June 30th update on PC, halfway into it I get this:

Clipboard01

Full path is Engine\Binaries\ThirdParty\GraniteSDK\Win64\release\grGranite.dll.

I am not willing to de-quarantine the file and let the download finish until someone from Funcom answers.

I have exactly the same problem (30.05.19, 19:00)

Avira is known for false flags in my experience. Even so, it would be a good idea for a dev to look into this. I started downloading the patch moments before I saw this thread. I’ll have my own antivirus run a scan on that particular folder just to be sure once it’s done, if it doesn’t pick anything up during the download.

I reinstalled the file and advised my avira to ignore it. I uninstalled all mods and canceled them from steam.
It doesnt help a thing, the game will not start, saying " an error occured while updating Conan Exiles (hard disc writing error)" E:/Steamlibrary/steamapps/downloading/440900/engine/binaries/thirdparty/graniteSDK/win64/release/grGRANITE.dll
And checking the installation files just led to reinstalling the grGranite.dll file, the rest seams ok.
Any ideas?

In your case I’d say Avira is still interfering with it somehow. But I’m unsure exactly how to fix it because I don’t use Avira. (See previously mentioned experience with false flags. Although I’ve seen worse, by the way. A lot worse. :wink: )

Check your quarantine and see if the file is there. Avira may have picked it up anyway when you reinstalled. You might try temporarily disabling Avira altogether to see if that works. If it does, you know for sure that Avira is the cause, for whatever reason.

Also, you’ll probably want to have steam verify the integrity of your game files.

I do not, however, recommend leaving Avira disabled or disabling it every time you want to run the game. Even with problems like this, it’s better to have it on, so you’ll have to keep looking for a more permanent solution.

Just FYI, my download just completed and a scan with my antivirus turned up negative.

False flag report. GraniteSDK is a staple for the UE4 engine. It’s extremely common in modern UE4 games.

1 Like

In my humble opinion, a more permanent opinion is the game not using files that raise detections… :wink:

I de-quarantined the file and added it to the list of ignores, so the game is patching now. Here’s to hoping it’s really safe and Granite SDK isn’t using resources to mine currency! :smiley:

OK, it really was just the (hopefully) false alarm of avira.
The only strange thing is, that it didn’t make any problems before.
I had a crash, abd just afterwards after restarting avira protested.
I made an exception for the file, and now everything works fine.
Thx for the help and the answers!

Thx for the help.
I uploaded it to virustotal, it showed that just avira was detecting this file, all other programms wouldn’t.

@Krivvin I am having the same issue. I uninstalled Conan Exiles, and then reinstalled it without being suscribed to any mods, and I am having the same issue. The game will not get past 98% when re-downloading the game on steam, and then it tells me that I have a
disk write error just like that one stated in your post
disc writing error)" E:/Steamlibrary/steamapps/downloading/440900/engine/binaries/thirdparty/graniteSDK/win64/release/grGRANITE.dll
I use the same anti virus software, and I have not been able to find a solution to the problem. Unfortunately I cannot reinstall the game, and I am not too tech savy so I dont know what to do with my anti virus software to play the game. Although I can say after this patch the game is now unplayable, and my Anti Virus also came up with the error. I would just like to know when this is fixed. I am getting really tired of having to waste 60gbs to constantly reinstall this game every time it has a patch.
I am beyond angry, and would like to know how long it will be before I can actually play the game I paid over 100$ for. Thank you to the devs and have a wonderful day since I will not. I honestly just wanted to come home chill in front of the computer, and play Conan Exiles. Yet again when I get home I am just

@Krivvin I did the same, and I advised my avira to ignore it, but I am getting the same error still when I try to reinstall. The game still does not start so I have no ideas. I wish I did, and I keep trying to google for a solution, but nothing at this time. Hopefully someone will address the issue…

Tried everything, and I cannot get the game to work. I tried to reinstall the game 3 times now, and I still get the same error. So as of now I am officially done. I tried to give this game a chance, but then this happens. I just dont understand why every patch has to break the game. A patch is supposed to fix things not make them worse…

You’re not alone, sadly this is still an issue. Several clients of players in our community are still affected by this issue. De-quarantining the file didn’t help, starting Steam as an admin, trying to verify via Steam or reinstalling the client either. I’d really appreciate a Dev looking into this.

You need to check the ‘Add exception’ box when de-quarantining the file.