Random lost connection to server

MP, rented server. No mods.

WHAT IN HELL IS CAUSING THIS?

I guess a wide array of possible reasons:

  • unstable server
  • problems with internet provider
  • hardware problems on your end (lan card, modem, switch, cable, too weak wifi signal…)
  • software problems (inappropriate settings on firewall, AV…)

To narrow down options, maybe a deeper analical approach is needed:

  • is this a problem from day 1 on this server?
  • are you the only one having this problem or is it the same for others there?
  • is there a correlation between drops and high number of connected players?
  • do you have problem with only this server or you have similar issues with some official or other private ones too?
  • did anyone inspect server logs around moments of disconnect?
  • … there are several more questions to be asked, but I guess you see where I am pointing. :face_with_monocle:

Also some light reading:

I have to find out what is causing this.
I happens every time I log in and it happens at random times. From a couple of minutes into the session up to several hours later. A lot of times it happens at the worst possible moment.
I need this to stop.
I don’t know if other people are experiencing this. Frankly I don’t know if they are or are not. I’ve not found any other posts about it unless they’ve been locked down already and it is impossible to post on locked topics.

This is a private, rented server

Don’t quiz me on my system. It’s been updated and it’s more than ADEQUATE.
EVERY THING ON MY SYSTEM AND SETUP AND INTERNET CONNECTION IS FINE.

I deeply apologize for trying to intrude your privacy in this matter with my unwarranted questions.
I will not waste your time anymore.

I will pray to Crom to show you a path to solution.
Honestly, best of luck!

2 Likes

I simply need to find out is what causing these random disconnects, then work out a solution to prevent this from happening.

There could be MANY reasons. Hence, me listing possible reasons from top of my head and asking question that would eliminate some reasons for your problem and maybe directly point to a solution.

there are 2 obvious paths for that (and they do not exclude each other):

  1. Provide as much info as possible (this sentence was on template when you created the thread).
    Someone with knowledge or direct experience could see and offer a solution.

  2. Start digging through old threads that describe similar problem (which it seems you already did)

I guess there are 2 main reasons for that

  • The author stopped responding, no one else had the need to post there, OR
  • A solution has been found.

Now some extrapolation from your post:

Press ESC and “Player list”.

When on the server, you can simply ask around and maybe get in touch with server owner.

If there are mods involved those could be causing disconnects. Also just from that piece of info, one can not exclude that it is too far away from you (high ping), or has connection and/or stability issues.

Please note: In this post there are no questions on my part. Just some explaining done on general situation that may (or may not) affect you and your problem directly.

Please feel free to proceed as you like. Good luck!

1 Like

@Meo, my personal kudos for the time you put into this to try to help the OP, despite the attitude.

/tip hat

Regards

jim

TY @Jim1.

You an I having lots of hours on CE can both agree that bugs like this can easily trigger bad emotions.
So, even if this discussion started on some bad terms, I see no reason that if all of us take a deep breath, clear our minds and start cooperating, the result would be very positive for all of us.

I don’t know how many hours either of you have put into this game.
But, rest assured that I’ve put in over 4000 hours into this since it was EA.
Now, let me make something clear:

I run (and admin) a private / rented “vanilla” server. (It’s hosted in Dallas, Texas at a primary data hub and I live in Florida).
There is only one other (who lives in Spain) that plays on it and so far (if I can understand Spanish using a translator with what literacy I do have in the language) she doesn’t seem to be having the same issue. (but, I could be wrong). She has had other issues, but rarely and nothing as frequent as I’ve been experiencing and it appears totally unrelated.

What is really odd, since my last post yesterday …
mysteriously … I have had absolutely no disconnects today and I’ve been in game going on 16 hours today.

From this experience, I get the impression that something is going on in the background exclusively of this game.
That’s what I need to find out and get to a workable solution.

Now, if the two of you have something personal to discuss, please take it somewhere else … preferably private and out of my thread. I need useful information, preferably from a programmer familiar with this game.

One other thing which is apparently connected to this issue.
I’ve posted on this issue and the topic was eventually locked without any solution found or implemented.
That issue (related with this) is extremely similar to this with two (2) exceptions.
That is during SP (solo) play (again, vanilla) an unexplainable game freeze occurs in exactly the same way it occurs in MP. Random times and very rarely did an extended session go by when there was no freeze.
HOWEVER: what’s different in this case is when the game locks up, it causes a complete system lockup. The only way out is by power off - hard reset (reboot).
The lockup is so severe that it even prevents any error logs from being written to the drive.
That’s where this issue differs because in MP;

  1. The game randomly freezes.
  2. Roughly 3 to 5 minutes pass before the game exits to the main menu. (2-5 MIN !!!).
    (keep in mind, occasionally the event will go into a complete system lockup).
  3. When the game exits to the main menu is when the “Lost connection to server” notification pops up.

This is an indication of a game engine related issue which excludes the system, the OS (Windows 10) and internet connection.
However the common denominator between MP and SP is the game server implementation itself exclusive of the network management since it runs the exact same server engine. Being that in MP, the server which runs it is located in an external location (another state). In SP, the server is run on the same machine.
This is an indication of a common issue in the server files.

For your questions regarding my system specs:

Computer Information:
Manufacturer: AMD (Mobo is Gigabyte)
Model: 990FXA-UD3 R5 (updated bios)
Form Factor: Desktop
No Touch Input Detected

Processor Information:
CPU Vendor: AuthenticAMD
CPU Brand: AMD FX™-9590 Eight-Core Processor
CPU Family: 0x15
CPU Model: 0x2
CPU Stepping: 0x0
CPU Type: 0x0
Speed: 4722 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Supported
SSE42: Supported
AES: Supported
AVX: Supported
AVX2: Unsupported
AVX512F: Unsupported
AVX512PF: Unsupported
AVX512ER: Unsupported
AVX512CD: Unsupported
AVX512VNNI: Unsupported
SHA: Unsupported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Unsupported

Operating System Version:
Windows 10 (64 bit)
NTFS: Supported
Crypto Provider Codes: Supported 311 0x0 0x0 0x0

Video Card:
Driver Not Detected
DirectX Driver Name: aticfx32.dll
Driver Version Not Detected
DirectX Driver Version: 26.20.13031.18002
Driver Date Not Detected
OpenGL Version: 4.6
DirectX Card: Radeon RX 580 Series
VendorID: 0x1002
DeviceID: 0x67df
Revision: 0xe7
Number of Monitors: 1
Number of Logical Video Cards: 1
No SLI or Crossfire Detected
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 20.75" x 11.65" (23.78" diag)
52.7cm x 29.6cm (60.4cm diag)
Primary Bus Type Not Detected
Primary VRAM Not Detected
Supported MSAA Modes: 2x 4x 8x

Sound card:
Audio device: Headphones (High Definition Aud

Memory:
RAM: 32732 Mb

Miscellaneous:
UI Language: English
Media Type: DVD
Total Hard Disk Space Available: 2765273 Mb
Largest Free Hard Disk Block: 1903839 Mb
OS Install Date: Dec 31 1969
Game Controller: None detected
VR Headset: None detected

The CPU is water cooled.
The system is connected to a Nighthawk Wi-Fi mobile hotspot via 3 ft. LAN cable.
The Wi-Fi hotspot receives and transmits to an indoor antenna (8 feet away) feeding through a signal booster amplifer to a roof mounted external antenna Tx/Rx full duplex mode on the 4G network to the ATT tower 3.4 miles away.
Signal strength is excellent and is not subject to signal fade due to inclement weather.
Ping hovers around 80ms average.

Glad to hear things are working better, but personally I hate when problems like this dissapear on their own without knowing the cause (just waiting to reappear).

There is high chance that someone from Funcom already follows this thread. If you want direct attention, in your next post you can call upon them by name like @Vahlok. (I suggest you start with Hugo and/or Ignasis, just add “@”). If you ment a player with programming skills, also high chance few of them read this.

That is far from excluded. Note that next few questions are not for my curiosity but someone may connect the dots:

  • does your problem exist ever since you started your server or only started “recently”?
  • do you experience similar problem when trying to play on other (official) servers, if you even tried recently?
  • do you have access to server logs? If there is something wrong with “game” in your case, logs could point to “what”

And one last thing, with all due respect:

If you wish your thread to be clean and focused on your problem, I suggest you do not deviate from the core subject. My comment was completely general.

1 Like

Before, in the beginning as it still occurs now, is the issue of persistence and this is well known. It is a flaw with the DBMS that was meant for mobile applications.
(example): Known and unlocked formulas for crafting inexplicably disappear from crafting menus. One possible fix is to take up the station and place it back down to reload the data from the game archives.
This DBMS is the beating heart of the game, and if it’s defective or unreliable, it makes the game unreliable and unstable.
This can have a detrimental effect on connection issues.

Well this is your hot dog. You fix that and you’ll fix the majority of game issues that even mods cannot address.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.