Remote change of weapon use by thralls

I am clearing the camp with two thralls, and suddenly a valuable craftsman flashed among the natives! … I urgently need to give the command to the thralls to change their smashing weapons to truncheons!

There was some kind of mod for this, tell me please.

“Better Thralls” mod will allow that.
More specifically, your thrall will switch to truncheons when you do (assuming they have one equipped).

1 Like

Thanks, I never noticed this feature. But now I turned it off, because, according to my repeated observations, it increases the frequency of the bug when followers freeze in a combat stance and do not fight.
I just found another mod - " Follower Remote" by our esteemed Xevyr.

I don’t really have much issue with my thralls becoming unresponsive, but know that it can be an issue with some.
Better Thralls has the ability to hand over your knocked out thrall to your horse (or other thrall), which completely prevents the crashing issue I get when dragging a thrall while riding my horse. That is extremely useful to me.

I see this very often, and not only with followers, but also with the guards. When they are attacked by not too strong enemies, they often freeze. In order to ‘revive’ them, they must be moved with a strong blow, and you can also heat the poor fellow yourself if pvp is enabled. :muscle:

Just send them into the camp with truncheons and then you have a spear and just come along behind them doing the finishes after the natives are out cold. After all you don’t always realize there’s a good dancer in the mix until it’s too late. Better safe than sorry :+1:

1 Like

Follower Remote, by @Xevyr , is also a good one. Very light weight and simple. You can switch between weapons and truncheons, as well telling them to take a potion, as long as you’ve put them in their inventory.

Yes, this is by far the easiest way.

Checked out the Xevyr mod. For some reason it doesn’t work for me. I press Shift+[arrow] - a cross menu appears, then I press [down arrow] - the truncheon icon starts flashing, but nothing changes. Also no text message appears and there are no items from this mod in the radial menus. I play on the Savage Wilds map but it doesn’t seem to make a difference.

That’s because @Testerle is stealing them :stuck_out_tongue:
Better thralls needs an update so that when you disable the “force truncheons” feautre, it doesn’t still enforce the setting on thralls equipping weapons. What’s happening is my mod equips it, but better thralls very quickly takes it away.

They worked fine in the past, just Funcom made the AI more aggressive so the mods had to monitor what weapons thralls are using to prevent them from switching.
Basically for the moment, the truncheon swapping portions of these two mods aren’t compatible

(I will probably also add some form of setting so people can disable my monitoring in case they want to use the truncheon mimicing from better thralls)

1 Like

This is how us dirty plebs on console cope… and we’re also dealing with excessive latency and whatnot. If we can do it, so can everyone else. It’s the most effective solution if you’re trying to avoid unnecessary modifications I imagine. But, alas, I’m not a PC user, so what do I know? :neutral_face:

I’m sorry, I didn’t quite understand. I have the ‘Better Thralls’ mod disabled, how can they conflict then? Or am I not talking about that?

If you are not using the better thralls mod, then mine should work without any issues

As long as you actually gave your follower both a weapon and a truncheon…

I didn’t read the entire discussion, just the first few posts and the message tagging me, I thought you’re using that one too.
Anyway, regarding this

While this sometimes happens with thralls once in a blue moon… It only happens frequently if you give them shields… Never give your thralls shields, it makes everything worse since they don’t know how to use it and plus you get this freezing bug frequently.

Alas, it doesn’t work… :sleepy:
Oh, I forgot to say that my truncheons is not vanilla.

I haven’t given shields to thralls in a long time.
On the EL map, thralls began to freeze en masse immediately after June 22. When I disabled ‘Better Thralls’, the freezes almost stopped, but there are more of them on the SW map. However, I learned to deal with them quickly.

Well, then try it with a vanilla one :man_shrugging:
Though it should work just fine even with modded ones… it selects the item in their inventory with the most concussive damage…
But I can assure you the mod works just fine and nobody reported any issue with it whatsoever.

Here, you can see it in action :smiley:

Been having issues with your mod too.
When I set them to use truncheons they use them fine for the most part as long as I use a vanilla (0 damage) truncheon to hit things.
When I hit anything with any weapon or modded truncheon that still had 1 damage they will often break like stated above.

The server I play on does not use better thralls.

It works even with 1 damage truncheons though, so that’s not the issue… however if it’s a heavily modded server, other mods might have similar stuff going on

And when YOU hit anything has absolutely no effect on my mod or what your thralls do (that’s better thralls), mine has your thralls attack with whatever weapon you set them to use, regardless of what your character is using…

I re-read this… it’s a bit confusing, so just to be sure you’re actually using it correctly… here’s how it’s supposed to work:

  • Have a thrall that has a weapon AND a truncheon in their inventory
  • Make the thrall actually Follow you
  • Press and hold the Shift+Down Arrow combination until the truncheon icon on that tiny interface does a GREEN flash (it’s not shift+arrow and then release shift and down arrow… it’s a single shift+down arrow combination where you have to keep holding BOTH keys, cuz this part was confusing in your description)


As for the alternative radial menu, it’s on the Command radial menu, not the one that you get when targeting a thrall, but the one you get when a thrall is following you, but you’re not targeting anything (the one that has the Move / Return / Attack / Stop commands)

Been spending over a week testing it trying to figure out what caused it and it’s the act of doing normal damage that triggers it.
He does not have better thralls on but there is a list.
I’m not sure how to link another thread but all the mods used are listed in the KY jelly server thread in this forum.
Is there any mod on that list you think might be causing it?

P.S. already been talking with the server owner trying to figure out why it’s happening. I seem to be the only one noticing the problem but we figured out that was a difference in our approach to thralliing.

You can just copy the link and then in your post paste it as normal… or you can select a portion of text and link to that:
Like this, here’s the link to the thread

If you describe the process and what’s actually happening, maybe I’ll have some ideas, off the bat I can’t really see any mods on that list that would stick out.

(I never tried a couple of them though, but I doubt it would be that as they don’t seem thrall centered)

I added a mini-tutorial above for Teng :stuck_out_tongue: could quickly look through that to see if that’s how you’re using it, as in their case I think it was simply not holding the right combination