Sandstorm mask .not working

Has there been a intentional change to the masks. My wife and I bringing a new player to our base sandstorm coming up every one dawns a mask he died we are dying but eating and aloe potions stay alive don’t work the same for poison either. Pvp private gportal server. Thanks

Any mods involved? I used the sandstorm mask last night, and it worked just fine.

No mods ps4 I will have to try again in fact we where on south side of river. In newbie area. Thanks for the response.

There is a commander helmets similar to sandstorm mask.

Sorry, missed the PS4 tag. No mods then.

There are a few helmets/masks that will protect you from the sandstorm, I believe the Set mask also works - have you tried that one?

1 Like

No but I will thanks again.

Other thing is, it might be like sulfer springs, you have to have the mask on, before you enter. Weird “bug”. If you don it after you start taking damage, it doesn’t stop it in the springs. Never tested it during sand storm though.



1 Like

We were caught in the sandstorm before we put on mask Thanks…

1 Like

Yes, it does, i put often sandstormmask on my archers on the walls.

1 Like

I’ve put my sandstorm mask on during a sandstorm in the past and gone from taking damage to being protected. But not since the latest round of patches so maybe it’s bugged now.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.