Season pass does not unlock DLC

Game mode: Both
Problem: Purchasing Content
Region: US


Bought the Season Pass on Xbox, now that it showed up. It installed the Turian DLC 10 mb unlock file on my console, same as all my other purchased DLCs. But in-game, the feats to use it are still locked. Deleting the Turian DLC and going back to the store, it is still listed at $9.99. I go to the Season Pass, hit install again and it downloads the Turan unlock again but still, I cannot use it in game.


Steps on how to reproduce issue:
1.
2.
3.
4.

took a picture of the store screen. Note that it is both installed and still $9.99

I have had the same issue, i contacted microsoft and after hours of trying they could find no fix so they believe the issue is on funcoms end, all they can do is refund you if it doesnt work. Hopefully funcom can fix it soon.

Did you purchase the Year 1 Season Pass or the Year 2 Season Pass? If you purchased the Year 1 Season Pass, it does not include the Turan DLC.

I am having the same issue. I opened a funcom ticket still no reply

Year 2. Already own the Y1 dlc.

Same problem here…

I joined the forums just to see if this was here. No response to this issue anywhere. Paid for content I can’t use. Needs a fix ASAP.

They are working on it. Hopefully quickly.

Ok so its not just me. Just got the season pass today and was like wth. Thought it was odd too that it shows I have the 10mb file for it but wasnt letting me access it in game.

Hey there,

Thanks for bringing this up to our attention. Our team is looking into it right now. Apologies for the frustration until we resolve this problem.

2 Likes

Quick update: We’re in talks with Microsoft hoping to fix this issue as soon as possible. We’ll update you all once this issue is resolved.

3 Likes

I have had this issue as well. Its not great but glad I’m not the only one so hopefully it’ll get figured out. I tried asking for a refund and they turned me down so I can’t even get it separately

Don’t suppose you have an update on this yet?

We’re still in talks with Microsoft. We’ll update you all once we have more concrete info.

2 Likes

I’m so anxious to build with turan. I’ve gotten 100k+ stone saved up already for starters… Although I just logged in and noticed I’m not where I logged out…and cleary I died while logged off…but just dashboarded so can’t even see…not sure why I would have died inside my base though…on a pve server at that

Edit: and this crap means I just lost my legendary equipment again…so tired of this crap

Did you fill your food and water meters? I’ve logged back in at half rather frequently.

Too hot? Too cold? Store you belongings in a chest and log out naked. No lost items.

Three days ago, but the problem continues…

Hey there,

Please keep this thread to discuss this issue only. For other issues, please open a new thread.