Seed of evil dlc Xbox not working

So it’s been 9 hour and still no fix for seed of evil dlc for Xbox come on now took my money and I can’t play

1 Like

Iv finished the game I’m lvl 75 have been to Eden and got the cut Scene payed at Microsoft store downloaded and there is not a Seed of evil for me to click on at my starting screen what’s the deal …

1 Like

Still nothing? I downloaded the dlc and won’t work for me either

So not working for me and I bought both no game pass, the dlc doesn’t show in my dowloaded games, the game still give me an ad to buy it, and when I goto the dlc on the site there is no option to download it

I have also brought the seed of evil dlc, before realising it wasn’t working I saw it was 10 mb. Which had me worried . I tied uninstalling, reinstalling the game, restarting my x box and nothing.
I’m typing this hoping this subject will get more attention.

Is somebody at least going to come on here an acknowledge that there is an issue and maybe give a timeframe? The silence is worrisome

Just saw that there was an update on that sticky from developers. Didn’t see that. At least we know they know! The wait continues…

I have the same. DLC doesn’t show in downloaded and the game suggests buying it. Could anyone help?

1 Like

Still no fix? Man… this is kind of ridiculous.

Mine won’t even load now. It jumps to dash as if there is a update but there is not one. I could at least play the core game weds

Still waiting…

1 Like

still waiting… going for a refund soon

1 Like

A one star ratings isn’t low enough for a mess like this. Paid money for a game that I haven’t been able to play for 3 days, they really should offer more than an apology.


4 days for me. It’s a mess. Seems like a mess across the board too. From a terrible switch port to PC issues to this nonsense on Xbox. Completely soured one of my favorites from last year. Shame.

Anyone who hasn’t checked the dlc is now working on x box one, I don’t know when it happened but it is working now

Barely. It crashes after every cutcene. Especially when you get to the ark. Can’t get past it…

1 Like

Yup. This is awful.

Same here. I am astonished that this could be out there and pass certification. Was elated and excited that I could finally play until the first crash… then second and third and so on…

It’s honestly unreal.

Hello, we deeply apologize for the issues with the launch, please rest assured that the developers are working hard to address all issues that have been reported.

i think i got up to 68 how did you get break 70s