Sloob account, only Premium Membership Sub option shows

I recently tried to reactivate my old sloob account and there was only the $15 option. I contacted support last week but haven’t gotten a response yet. Today I couldn’t even login to that account, got Authentication failed, please check your password and try again and when I did a password reset thanking maybe I got wrong password it was the same result. I can login to my other account but this sloob account has the authentication message now.

I hope this is a sign Funcom Support is working on making my Sloob account have the $5 sub option again but I’m not sure.

I’ve searched forums and seen people say try the old account page but it seems to forward to the new one.

I am just wondering if anyone else had this problem. I hope I get a response from support soon.

1 Like

Hi Skuly,

first, i know your feelings :laughing:.

I have also a sloob account and also sent 2 messages to the support (last year and this year), that they should add the sloob payment option to the new account site, but never got an answer, so i hope you get one, but it will take weeks aleast :wink:

About authentication , that troubles i had them too. As i remember they use “fail2ban”, so they block your IP for an amount of time (i dont know how long ^^) → try from other ip adresses both passwords (old and new).
If you have no fixed ip at home, just turn off/on you router and you should get a new ip → try login again.
As i remember, I logged in with my smartphone :sweat_smile:.

If you can login again:
I got my sloob-account working via , but it took me 1 hour, cause i had to change the payment from creditcard to debitcard, cause i live in EU and the creditcard is forced to use 3DES ,which is not working on that old account-pages.
I clicked “reactivate” → the payment fails → then there is something like “change payment” , that way i got it working after 2 tries.

But i hope funcom just add the sloob-payment ,not only the yearly upgrade offer ~ 60€ :face_with_raised_eyebrow:.

best wishes for your support-ticket

1 Like


I tried with VPN and didn’t work. I’ll try to pull a new IP from my modem and see if your suggestion works.

Ok did another password reset after I changed my ip.

I was able to get back to the old site through tsw the link but it looks like my accounts got upgraded it’s still only offering the $15+ subs. There is only one character listed and it was my lowbie froob enforcer so if I upgraded I should have had more characters.

And in the screenshot it shows no previous payment history so I don’t remember (how could I after 13 years 2010) ever upgrading this account.

I’m going to repeat myself again, No characters on the account but the froob I remember making and not taking far, and no payment history saying I ever upgraded.

Support doesn’t respond so I guess I’ll never figure this out.

Thanks for trying to help me, I really wanted to come back and play my sloob account, I don’t want to pay $15 a month or be forced to pay $95 for a year that I might not even use 6 months of.

I wish they never ended or that they brought back the sloob program. Or made SL free up to a certain level or the sloob accounts level locked, they could have had it level locked at 100 or 150 and offered one time level unlocks or something, but instead they just stopped offering $5 sl accounts.

I lost a lot of respect for Funcom when they did that, and it was all downhill from there.

I just looked in my old email account and found an email from 2010 that might have been about this account.

I totally forgot how bad Funcom support was even 13 years ago.
13 years later and I still can’t access my sloob account. Although I hadn’t tried again until last week.


i’m sorry for your loss of the shadowlands subscription :anguished:

Yes, somehow it was upgraded in the past, cause on my account the membership status shows “Shadowlands Subscription”:


And i understand your opinion about the yearly sub, that’s the reason why i keep my sloob-account open.

best regards

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.