Some of the new Journey steps arent registering

“Chef” step 9 - use dryer to make dried meat. Not working. Have tried various meats.

“Beastmaster” - “Feed your pet” - gave shaleback plant fiber - nothing.

And yes, i have each journey active when i am doing the steps mentioned.

For the chef one, try taking the meat out of the dryer after it’s done. That triggered it for me.

1 Like

For the Beastmaster one… ‘USE’ the food in the pet’s inventory.

Some of them do take a little virtual percussive maintenance to get them to register. There’s a couple I had to repeat the action two or three times before it finally gave me credit for it, like placing a crafting thrall on a workbench.

Ive tried that multiple times, no good.

That actually worked for some crazy reason!

1 Like

For the chef achievement i had to click on the “Take” button in the dryer menu while selecting the dried meat. Simply double clicking with the mouse or using the “take all” button wasnt good enough, which is silly.

Weirdly, this doesn’t work for me. Plant fiber for herbivores doesn’t have a use option, and then I tried use on feral flesh but my character ate it, not the panther.

did you move it to the pets inventory and use it from there?

I did. But apparently I ate out of my pet’s inventory. lol

Some of them complete when whatever you are making completes and some you have to remove it for the completion. And some I haven’t gotten to complete at all. Funcom, a little continuity please!

So far I’ve managed to get them all to complete. At least the ones I’ve gone through anyway. I had to do some of them two, three, maybe even half a dozen times to get them to trigger, but they did eventually register.

Another bugged journey step: went into sorcerer’s cave, went far enough to get the book, did not get the completion. Went in 3 times, still stuck.

edit: Had to relog, go back in, TOUCHED the empty brazier outside the entrance of the last cavern, THEN it worked.

What was your condition to get the convert a crafter to complete. I have captured all levels of multiple different crafters and placed then in, at this point every level of the wheel. I really want that purple lotus recipe.

If I remember right, that was one where I had to convert him, put him on a bench, remove him from the bench, put him back, pull him out again and place him a third time before it finally took. I only had the lowest level wheel at the time, and it was a level one thrall I just grabbed out of a nearby camp, but I don’t think that matters.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.