Structures/whole Bases disappearing on server restart


#1

Game mode: [Online/Privat Server]
Problem: [ Bug]
Region: [Europe]

Greetings,

since about 2 Weeks large parts of buildings are disappearing on our server. Till now there are at least about 6 known cases where significant amount of structures and even whole bases are gone after one of the daily server restarts (we r having 3).
I honestly dont know how to catch the phenomenon further- we examined every known case closly but fail to recognise any pattern.
Fact is the damage is severe as some clans have lost most to all progress except their levels.
We love the game and can surly live with the minor bugs and challenges, but seriuosly: this is disastrous. Not to know if your base is gonna survive the next restart in a competetive environment (beside from losing weeks of work) is driving the first members of our community to quit- so we urge for a reply.

EDIT

Summory:

  • only one of the bases used support beams
  • no regular problems with the server (crashes, lags, etc)
  • decaytimer has never been activated (furthermore structures of different “age” and material r hit at the same time)

#2

Is the decay-system turned on ?

If yes, this could be the culprit.
I know there a sever issues and bugs right now still with it. Maybe turning it off while they fix it ?
For my part i have turned it off, and in SP and on my own privat server. And i don’t experiment disaspearing bases and such at this moment.


#3

No, decay-system is off since the start. We r a bigger active Adminstaff on an RP-Pvp-Server, we clear out leftovers or non-ruleconfirm buildings regulary, its simply not needed.


#4

using support-beams maybe ?

They lose support actually at server restart, and the structures hold or linked to them may vanish then.


#5

One of the towerbases had- which still not explains why it vanished to the last foundation… besides from not giving any infos on what happened in the other bases which didnt use any.


#6

I have read that even though the decay system is turned off, the timers are still ticking. Whilst the buildings remain standing, they are in fact decayed buildings. This is fine until the decay system is turned on, even for a moment, the server would see all those buildings as decayed and remove them.

I suspect that either you have turned the decay system on for a moment or that there is some kind of bug in the server as it boots up which is not deactivating the decay system until it’s too late. Only a dev would be able to confirm/deny this, sorry.


#7

We included this theory from the start and again: its highly unlikly to be the reason alone or at all, as structures of same material with different age are hit and we didnt turn on decay at any point. Latest incident was yesterday- one of the first buildings on the server disappeared whole and large parts of a building nearby (which was almost 2 weeks younger). So unless u find another factor triggering the event, it just doesnt make sense…

Edit: biggest parts of the second building disappearing were on top (so youngest), others single pieces at different levels- while the building next to it vanished as whole. I checked for structural integrety, speciel used buidlingelements, spawnpoints nearby, number of buildingpieces etc etc- still fail to find any pattern.


#8

Have you had any server crashes where the database could have been corrupted? When your server does crash or develope a lot of lag, do you run the database checker tool before relaunching the server? Just clutching at straws :slight_smile:


#9

I appreciate the brainstorming, but nope: server runs smooth and sound.


#10